File Cabinet Problem

Ken
2009-01-08
2013-05-20
  • Ken
    Ken
    2009-01-08

    I'm having a problem with File Cabinet. I got it running and was able to upload files. When I go to the group of files and I click on the
    file description link  it let me type on the upload window it give me an error of  /filecabinet/3 was not found on this server. But right beneath
    that description link is another link showing the actual file name it's linked to. You click on the file name link and you can download it.
    What is the purpose of listing the description as a link (that doesn't work) right above the file name as a link that does work.  I can send screenshots if this is not clear.

     
    • I think this was a bug in 1.6.0. Please test in 1.6.1 and email me your results if you have problems.

       
    • Ken
      Ken
      2009-01-19

      ok, upgraded to 1.6.1. Still having the same problem. The file description link is pointing to a file that doesn't even exist. All the description links are pointing to a hostname/filecabinet/1-??. I go and look for that file  and there are no files under that hostname/filecabinet directory except about 10 folders that have nothing in them. But the link to the actual file is pointing to hostname/file/filecabinet/21/filename which actually works.

       
      • Sounds to me like mod_rewrite is not working on your server. This has been discussed many times at phpwsforums.com

        Essentially...

        Sounds like your server doesn't support mod_rewrite (needed for the short URLs). You can read about this at /docs/Mod_Rewrite.txt. You can also just disable phpws from using it by editing /config/core/config.php and down near the bottom, change define('MOD_REWRITE_ENABLED', TRUE); to define('MOD_REWRITE_ENABLED', FALSE);