Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

ide, scsi and usb devices don't show up

Help
Anonymous
2012-03-27
2012-12-12

  • Anonymous
    2012-03-27

    In the "hardware information" section there are no information on ide, scsi and usb devices, it displayed "none.
    I have SATA hard drive and an usb flash drive connected to the machine. How do i get the information on them in phpsysinfo?
    Debug mode is on, no error are displayed.

     
  • Inability to respond with so little information about the version of software / system, the lack of logs from Apache / IIS etc.

     

  • Anonymous
    2012-03-28

    OS: FreeBSD 9.0-RELEASE
    Apache 2.2.22
    phpSysInfo - 3.0.16
    no errors are displayed in Apache's logs, but if necessary, I will provide them as well.

     

  • Anonymous
    2012-04-02

    Nothing changed, still no information on USB and SATA devices.

     
  • Attach file /var/run/dmesg.boot or sent to namiltd(AT)users(DOT)sourceforge(DOT)net

     

  • Anonymous
    2012-04-03

    Copyright (C) 1992-2012 The FreeBSD Project.
    Copyright (C) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
            The Regents of the University of California. All rights reserved.
    FreeBSD is a registered trademark of The FreeBSD Foundation.
    FreeBSD 9.0-RELEASE #2: Sat Mar 24 02:37:53 MSK 2012
        root@atomserver:/usr/obj/usr/src/sys/atomkernel i386
    CPU: Intel(R) Atom(TM) CPU D2700   @ 2.13GHz (2133.46-MHz 686-class CPU)
      Origin = "GenuineIntel"  Id = 0x30661  Family = 6  Model = 36  Stepping = 1
      Features=0xbfebfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,DTS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE>
      Features2=0x40c31d<SSE3,DTES64,MON,DS_CPL,TM2,SSSE3,xTPR,PDCM,MOVBE>
      AMD Features2=0x1<LAHF>
      TSC: P-state invariant, performance statistics
    real memory  = 4294967296 (4096 MB)
    avail memory = 3400560640 (3243 MB)
    Event timer "LAPIC" quality 600
    ACPI APIC Table: <ALASKA A M I>
    FreeBSD/SMP: Multiprocessor System Detected: 4 CPUs
    FreeBSD/SMP: 1 package(s) x 2 core(s) x 2 HTT threads
    cpu0 (BSP): APIC ID:  0
    cpu1 (AP/HT): APIC ID:  1
    cpu2 (AP): APIC ID:  2
    cpu3 (AP/HT): APIC ID:  3
    ioapic0 <Version 2.0> irqs 0-23 on motherboard
    kbd1 at kbdmux0
    acpi0: <ALASKA A M I> on motherboard
    acpi0: Power Button (fixed)
    Timecounter "HPET" frequency 14318180 Hz quality 950
    Event timer "HPET" frequency 14318180 Hz quality 450
    Event timer "HPET1" frequency 14318180 Hz quality 440
    Event timer "HPET2" frequency 14318180 Hz quality 440
    acpi0: reservation of 67, 1 (4) failed
    acpi0: reservation of 0, 4000 (3) failed
    Timecounter "ACPI-safe" frequency 3579545 Hz quality 850
    acpi_timer0: <24-bit timer at 3.579545MHz> port 0x408-0x40b on acpi0
    cpu0: <ACPI CPU> on acpi0
    cpu1: <ACPI CPU> on acpi0
    cpu2: <ACPI CPU> on acpi0
    cpu3: <ACPI CPU> on acpi0
    pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
    pci0: <ACPI PCI bus> on pcib0
    vgapci0: <VGA-compatible display> port 0xf100-0xf107 mem 0xdfb00000-0xdfbfffff irq 16 at device 2.0 on pci0
    hdac0: <Intel 82801G High Definition Audio Controller> mem 0xdff00000-0xdff03fff irq 22 at device 27.0 on pci0
    pcib1: <ACPI PCI-PCI bridge> irq 16 at device 28.0 on pci0
    pci1: <ACPI PCI bus> on pcib1
    re0: <RealTek 8168/8111 B/C/CP/D/DP/E PCIe Gigabit Ethernet> port 0xe000-0xe0ff mem 0xdfe04000-0xdfe04fff,0xdfe00000-0xdfe03fff irq 16 at device 0.0 on pci1
    re0: Using 1 MSI-X message
    re0: Chip rev. 0x2c800000
    re0: MAC rev. 0x00000000
    miibus0: <MII bus> on re0
    rgephy0: <RTL8169S/8110S/8211 1000BASE-T media interface> PHY 1 on miibus0
    rgephy0:  none, 10baseT, 10baseT-FDX, 10baseT-FDX-flow, 100baseTX, 100baseTX-FDX, 100baseTX-FDX-flow, 1000baseT, 1000baseT-master, 1000baseT-FDX, 1000baseT-FDX-master, 1000baseT-FDX-flow, 1000baseT-FDX-flow-master, auto, auto-flow
    re0: Ethernet address: bc:5f:f4:1f:de:f2
    pcib2: <ACPI PCI-PCI bridge> irq 17 at device 28.1 on pci0
    pci2: <ACPI PCI bus> on pcib2
    xhci0: <XHCI (generic) USB 3.0 controller> mem 0xdfd00000-0xdfd07fff irq 17 at device 0.0 on pci2
    xhci0: 32 byte context size.
    usbus0 on xhci0
    pcib3: <ACPI PCI-PCI bridge> irq 18 at device 28.2 on pci0
    pci3: <ACPI PCI bus> on pcib3
    pcib4: <ACPI PCI-PCI bridge> irq 19 at device 28.3 on pci0
    pci4: <ACPI PCI bus> on pcib4
    uhci0: <Intel 82801G (ICH7) USB controller USB-A> port 0xf0a0-0xf0bf irq 23 at device 29.0 on pci0
    uhci0: LegSup = 0x2f00
    usbus1: <Intel 82801G (ICH7) USB controller USB-A> on uhci0
    uhci1: <Intel 82801G (ICH7) USB controller USB-B> port 0xf080-0xf09f irq 19 at device 29.1 on pci0
    uhci1: LegSup = 0x2f00
    usbus2: <Intel 82801G (ICH7) USB controller USB-B> on uhci1
    uhci2: <Intel 82801G (ICH7) USB controller USB-C> port 0xf060-0xf07f irq 18 at device 29.2 on pci0
    uhci2: LegSup = 0x2f00
    usbus3: <Intel 82801G (ICH7) USB controller USB-C> on uhci2
    uhci3: <Intel 82801G (ICH7) USB controller USB-D> port 0xf040-0xf05f irq 16 at device 29.3 on pci0
    uhci3: LegSup = 0x2f00
    usbus4: <Intel 82801G (ICH7) USB controller USB-D> on uhci3
    ehci0: <Intel 82801GB/R (ICH7) USB 2.0 controller> mem 0xdff05000-0xdff053ff irq 23 at device 29.7 on pci0
    usbus5: EHCI version 1.0
    usbus5: <Intel 82801GB/R (ICH7) USB 2.0 controller> on ehci0
    pcib5: <ACPI PCI-PCI bridge> at device 30.0 on pci0
    pci5: <ACPI PCI bus> on pcib5
    rl0: <RealTek 8139 10/100BaseTX> port 0xd000-0xd0ff mem 0xdfc10000-0xdfc100ff irq 21 at device 0.0 on pci5
    miibus1: <MII bus> on rl0
    rlphy0: <RealTek internal media interface> PHY 0 on miibus1
    rlphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
    rl0: Ethernet address: 00:11:6b:36:de:b4
    isab0: <PCI-ISA bridge> at device 31.0 on pci0
    isa0: <ISA bus> on isab0
    ahci0: <Intel ICH7 AHCI SATA controller> port 0xf0f0-0xf0f7,0xf0e0-0xf0e3,0xf0d0-0xf0d7,0xf0c0-0xf0c3,0xf020-0xf03f mem 0xdff04000-0xdff043ff irq 19 at device 31.2 on pci0
    ahci0: AHCI v1.10 with 4 3Gbps ports, Port Multiplier not supported
    ahcich0: <AHCI channel> at channel 0 on ahci0
    ahcich1: <AHCI channel> at channel 1 on ahci0
    ichsmb0: <Intel 82801GB (ICH7) SMBus controller> port 0xf000-0xf01f irq 19 at device 31.3 on pci0
    smbus0: <System Management Bus> on ichsmb0
    smb0: <SMBus generic I/O> on smbus0
    acpi_button0: <Power Button> on acpi0
    acpi_button1: <Sleep Button> on acpi0
    atrtc0: <AT realtime clock> port 0x70-0x77 irq 8 on acpi0
    atrtc0: Warning: Couldn't map I/O.
    Event timer "RTC" frequency 32768 Hz quality 0
    attimer0: <AT timer> port 0x40-0x43,0x50-0x53 irq 0 on acpi0
    Timecounter "i8254" frequency 1193182 Hz quality 0
    Event timer "i8254" frequency 1193182 Hz quality 100
    atkbdc0: <Keyboard controller (i8042)> port 0x60,0x64 irq 1 on acpi0
    atkbd0: <AT Keyboard> irq 1 on atkbdc0
    kbd0 at atkbd0
    atkbd0:
    ppc1: <Parallel port> port 0x378-0x37f,0x778-0x77f irq 5 drq 3 on acpi0
    ppc1: SMC-like chipset (ECP/EPP/PS2/NIBBLE) in COMPATIBLE mode
    ppc1: FIFO with 16/16/9 bytes threshold
    ppbus0: <Parallel port bus> on ppc1
    plip0: <PLIP network interface> on ppbus0
    lpt0: <Printer> on ppbus0
    lpt0: Interrupt-driven port
    ppi0: <Parallel I/O> on ppbus0
    uart0: <16550 or compatible> port 0x3f8-0x3ff irq 4 flags 0x10 on acpi0
    pmtimer0 on isa0
    sc0: <System console> at flags 0x100 on isa0
    sc0: VGA <16 virtual consoles, flags=0x300>
    vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
    ata0 at port 0x1f0-0x1f7,0x3f6 irq 14 on isa0
    ata1 at port 0x170-0x177,0x376 irq 15 on isa0
    ppc0: cannot reserve I/O port range
    coretemp0: <CPU On-Die Thermal Sensors> on cpu0
    coretemp0: Can not get Tj(target) from your CPU, using 100C.
    p4tcc0: <CPU Frequency Thermal Control> on cpu0
    coretemp1: <CPU On-Die Thermal Sensors> on cpu1
    coretemp1: Can not get Tj(target) from your CPU, using 100C.
    p4tcc1: <CPU Frequency Thermal Control> on cpu1
    coretemp2: <CPU On-Die Thermal Sensors> on cpu2
    coretemp2: Can not get Tj(target) from your CPU, using 100C.
    p4tcc2: <CPU Frequency Thermal Control> on cpu2
    coretemp3: <CPU On-Die Thermal Sensors> on cpu3
    coretemp3: Can not get Tj(target) from your CPU, using 100C.
    p4tcc3: <CPU Frequency Thermal Control> on cpu3
    Timecounters tick every 1.000 msec
    ipfw2 initialized, divert enabled, nat loadable, rule-based forwarding enabled, default to deny, logging disabled
    DUMMYNET 0 with IPv6 initialized (100409)
    load_dn_sched dn_sched FIFO loaded
    load_dn_sched dn_sched PRIO loaded
    load_dn_sched dn_sched QFQ loaded
    load_dn_sched dn_sched RR loaded
    load_dn_sched dn_sched WF2Q+ loaded
    hdac0: HDA Codec #0: VIA VT1708S_4
    pcm0: <HDA VIA VT1708S_4 PCM #0 Analog> at cad 0 nid 1 on hdac0
    usbus0: 5.0Gbps Super Speed USB v3.0
    usbus1: 12Mbps Full Speed USB v1.0
    usbus2: 12Mbps Full Speed USB v1.0
    usbus3: 12Mbps Full Speed USB v1.0
    usbus4: 12Mbps Full Speed USB v1.0
    usbus5: 480Mbps High Speed USB v2.0
    ugen0.1: <0x1b21> at usbus0
    uhub0: <0x1b21 XHCI root HUB, class 9/0, rev 3.00/1.00, addr 1> on usbus0
    ugen1.1: <Intel> at usbus1
    uhub1: <Intel UHCI root HUB, class 9/0, rev 1.00/1.00, addr 1> on usbus1
    ugen2.1: <Intel> at usbus2
    uhub2: <Intel UHCI root HUB, class 9/0, rev 1.00/1.00, addr 1> on usbus2
    ugen3.1: <Intel> at usbus3
    uhub3: <Intel UHCI root HUB, class 9/0, rev 1.00/1.00, addr 1> on usbus3
    ugen4.1: <Intel> at usbus4
    uhub4: <Intel UHCI root HUB, class 9/0, rev 1.00/1.00, addr 1> on usbus4
    ugen5.1: <Intel> at usbus5
    uhub5: <Intel EHCI root HUB, class 9/0, rev 2.00/1.00, addr 1> on usbus5
    ada0 at ahcich0 bus 0 scbus0 target 0 lun 0
    ada0: <WDC WD5000AAKX-001CA0 15.01H15> ATA-8 SATA 3.x device
    ada0: 300.000MB/s transfers (SATA 2.x, UDMA6, PIO 8192bytes)
    ada0: Command Queueing enabled
    ada0: 476940MB (976773168 512 byte sectors: 16H 63S/T 16383C)
    ada0: Previously was known as ad4
    SMP: AP CPU #1 Launched!
    SMP: AP CPU #3 Launched!
    SMP: AP CPU #2 Launched!
    Root mount waiting for: usbus5 usbus4 usbus3 usbus2 usbus1 usbus0
    uhub0: 4 ports with 4 removable, self powered
    uhub1: 2 ports with 2 removable, self powered
    uhub2: 2 ports with 2 removable, self powered
    uhub3: 2 ports with 2 removable, self powered
    uhub4: 2 ports with 2 removable, self powered
    Root mount waiting for: usbus5
    Root mount waiting for: usbus5
    Root mount waiting for: usbus5
    uhub5: 8 ports with 8 removable, self powered
    Trying to mount root from ufs:/dev/ada0a …
    WARNING: / was not properly dismounted

     
  • Strange but the SATA drive and rudimentary information on the USB are displayed correctly on new revision from SVN.
    Look at : http://www.2shared.com/photo/9UXE0T9C/freebsd.html ihis is the result of your boot.msg.

     

  • Anonymous
    2012-04-03

    So what should I do to get that information showed up in my phpsysinfo?

     

  • Anonymous
    2012-04-03

    Ok, I solved the problem by deleting the phpsysinfo directory and installing the SVN revision all over again.
    But now I got an error:

    errorHandlerPsi :

    PHP throws a error
    Level : 8 Message : Use of undefined constant PSI_SHOW_NETWORK_INFOS - assumed 'PSI_SHOW_NETWORK_INFOS' File : /usr/local/www/phpsysinfo/includes/xml/class.XML.inc.php Line : 152

     
  • Add text:
    define('PSI_SHOW_NETWORK_INFOS', false);
    or:
    define('PSI_SHOW_NETWORK_INFOS', true);

    to Your config. php

    Try new revision 557 from SVN.

     

  • Anonymous
    2012-04-03

    All issues resolved. Thank you.

     
  • There is no problem. By the way, please check the SVN revision 560 and display information about USB devices.
    Thank you for your cooperation.

     

  • Anonymous
    2012-04-04

    Thanks, but I still don't see attached USB flash drive, only root hubs. Is it normal?

     
  • Try SVN revision 561 but at the moment Phpsysinfo only sees the devices connected before booting.