#405 Use of php deprecated function "split()"

closed-fixed
nobody
None
5
2011-07-18
2011-04-26
Bjoern Boschman
No

See also: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=597595

When trying to launch phpsysinfo from a browser : http://localhost/phpsysinfo/
we first get a redirect to http://localhost/phpsysinfo/index.php?disp=dynamic
with a "Loading... please wait!" html message
then an alert popup "Error loading XML document" and nothing more.

Looking in error.log we found the cause of the problem :
Use of php deprecated function "split()" -> error

http://php.net/split :
This function has been DEPRECATED as of PHP 5.3.0

So replacing split with explode seems to solve this..

An outdated patch can also be found in the Debian bugreport

Discussion

  • Erkan
    Erkan
    2011-04-26

    Hello,

    Thanks for the report. All split function seems to by replaced by preg_split since PhpSysInfo 3.0.1

    Regards,

     
  • Erkan
    Erkan
    2011-05-06

    • status: open --> closed
     
  • Erkan
    Erkan
    2011-05-06

    • status: closed --> open
     
    • status: open --> closed
     
    • status: closed --> closed-fixed