Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#12 Win32 CPU Usage

0.5.0
closed-wont-fix
nobody
MAIN (11)
5
2004-03-11
2004-02-26
Darren Wolfe
No

If SmartIRC is run under win32, the CPU usage stays at
maximum all the time.

I believe this is because the usleep function is not
supported in win32 - if the function is changed to sleep
(1) (ok its a hack) then cpu usage becomes negligable.

Discussion

  • Mirco Bauer
    Mirco Bauer
    2004-03-11

    • status: open --> closed
     
  • Mirco Bauer
    Mirco Bauer
    2004-03-11

    • status: closed --> closed-wont-fix
     
  • Mirco Bauer
    Mirco Bauer
    2004-03-11

    Logged In: YES
    user_id=598557

    this is not a bug, windows doesn't allow resource handling
    when fsocks are used, this is more a windows bug. the
    usleep() _must_ be used or all timers in SmartIRC don't work
    right (flood protection, time handlers etc)

    The fix is to use the php socket extension under windows and
    activate it in SmartIRC