Rather than allowing the library to optimally choose ther version to use, I would like to force the generator to use a particular version perhaps by passing an optional parameter. Where and how within the library structure could this best be implemented?