After install error

Help
stefano664
2007-09-11
2013-04-24
  • stefano664
    stefano664
    2007-09-11

    Hello,
      I have tried to install two versions of phpmylibrary, the 2.2.1-2 and 2.2.1-3, but I have the same problem. I follow the installer, the prerequisites are ok, but when I click to try the program (or connecting to http://localhost/phpmylibrary\) the server response with a page like the follow text:

    setBasedir($tmpldir); return true; } function Template() { global $template; return $template; } function FilteringInit() { global $filter; $filter = new InputFilter(); return true; } function Filtering() { global $filter; return $filter; } function InputFilter($input="") { $filter = Polerio::Filtering(); $ret = $filter->process($input); return $ret; } function DBInit() { // Get database parameters global $config; $dbtype = $config['dbtype']; $dbhost = $config['dbhost']; $dbname = $config['dbname']; $dbuname = $config['dbuname']; $dbpass = $config['dbpass']; // Database connection is a global (for now) global $dbconn; // Start connection $dbconn = ADONewConnection($dbtype); $dbh = $dbconn->Connect($dbhost, $dbuname, $dbpass, $dbname); if (!$dbh) { $dbpass = ""; die("$dbtype://$dbuname:$dbpass@$dbhost/$dbname failed to connect" . $dbconn->ErrorMsg()); } global $ADODB_FETCH_MODE; $ADODB_FETCH_MODE = ADODB_FETCH_NUM; // force oracle to a consistent date format for comparison methods later on if (strcmp($dbtype, 'oci8') == 0) { $dbconn->Execute("alter session set NLS_DATE_FORMAT = 'YYYY-MM-DD HH24:MI:SS'"); } return true; } /** * get a list of database connections * @returns array * @redturn array of database connections */ function DBGetConn() { global $dbconn; return array($dbconn); } function DBGetTables() { global $table; return $table; } function PhpMyLibrary() { global $site_footer; $some = "@ PhpMyLibrary 2.0.3-1"; return $site_footer[1]."

    and more and more.... what happened? How I can repair it? Thanks and excuse for my bad english...

     
  • Renaud
    Renaud
    2012-05-28

    It's because PHPMyLibrary uses short php tags.  Ex <? instead of <?php.  You can fix this by modifying the php.ini file.  Look for the variable short_open_tag and set it to on.