Blank Pages In Chat Rooms...

Help
Blake Cook
2009-09-03
2013-12-06
  • Blake Cook
    Blake Cook
    2009-09-03

    I had to manually install the software. The installer incorrectly set some of the file and folder permissions to strange settings, which I have corrected. Now, all is installed but when I try to enter a Chat room, all that displays is a blank page, no errors. The admin area seems to work correctly and the initial index page does too. I have checked the site logs to see if there is anything there that could shed some light on the problem but that hasn't helped at all...

    Thanks in advance for your assistance...

     
    • Blake Cook
      Blake Cook
      2009-09-05

      I wish the fix was that easy. The installer did change permissions of a few folders but it wasn't to 777. They were set to strange settings such as 1213, which really didn't make any sense. I had corrected those settings. And since that didn't seem to resolve the problem, I started from scratch by uploading the files to a new folder and manually installed the software without ever running the installer. Unfortunately, I saw the same results, a blank page when trying to log into any of the rooms...

      I responded to your email, so hopefully the RC6 package will take care of this problem. I added phpMyChat-Plus to the subject line so that it would not be mistaken for junk email...

      Nightrider

       
      • Hmmm...
        I send you the package in a second.
        On the other hand, try to remove the .htaccess file from the root chat folder. Might be a restriction of the server to use those directives.
        Another reason could be that the server is running on safe mode or with some strange particular restrictions. I never seen pmp running fine on free hosting servers, mainly because the mysql limitations, but also php has very low restrictions, in order to save resources.
        God knows...
        Ciprian M.

         
    • Blake Cook
      Blake Cook
      2009-09-03

      I should have included a link too. Here it is:

      http://waldo.200u.com/chat/index.php

       
      • OK. I suspect you still have the folder "chat/config" wrongly set to 777 - change it manually to 755 pls (same for the root "chat" folder).
        I have to apologize for the inconvenience, I'm not sure why is this happenening on some installations (not always though). The installer is supposed to temporary chmod these folder to 777 so it can add/delete some files on new installations or upgrads, but it should safely chmod them back to 755. At some point, on certain hosting servers, this reversion is going nuts, unfortunately.
        For the last 2 years, I only work on the new 1.93 version http://ciprianmp.com/plus, which never claimed to be doing this strange chmod, so if you want i can send you the latest packge. Just let me know ;)
        Let me know if chmoding these 2 folders make the things work right.
        PS: Also make sure you check all the permissions mentioned as per manual instructions.txt file.

        All the best for now!
        Ciprian M.

         
    • Sorry for the typos, is not necesary about my language skills limitations, but mostly my rush and my stupid keyboard...
      Same C.M.

       
    • Blake Cook
      Blake Cook
      2009-09-04

      Hi Ciprian,

      I had to install this manually since the installer wouldn't work correctly on this server. I never set the chat or config folder to 777 during the install process. The owner of the site uploaded the files, so I'm hoping that something went wrong with the upload. I'm going to try uploading a fresh copy of the files to see if that makes any difference. I would like to try the latest package too if uploading the files again doesn't correct this problem...

      Don't worry about the typos or your language skills. I offer online tech support too and help people who have a lot more trouble than you do, and some of them are native English speakers. Your English language skills are far superior to my foreign language skills. You have nothing to apologize for...

      I appreciate your assistance with this...

      Nightrider

       
    • Blake Cook
      Blake Cook
      2009-09-04

      Ok, I uploaded a clean copy of the software I downloaded from SourceForge but it doesn't look like the same version that the owner of the site had uploaded. My copy doesn't include the administrator links on the login page. Since it doesn't know that I am an admin until after I have logged in, I'm not sure why the previous version was showing those options since after I logged into a Chatroom, a blank page was displayed...

      If you could provide the latest package, I would like to try it and see if that corrects the problem...

      I appreciate your help with this...

      Nightrider

       
      • As I said, you chat and/or config perms are set to 777, that's why this is happening. I didn't say you chmod that manually, but the instaler did it after first run and failure. So change them both to 755.
        I'll send you the package by email.
        Ciprian M.

         
  • Andy
    Andy
    2013-12-05

    Hi,

    I just installed the newest version 1.94 and am having similar problems. Once the installer was finished, I only see a white screen. You check the URL at http://testchat.aiiradio.net/plus/ . Permissions should be ok, and the install folder was renamed. Help!!

     
  • Andy
    Andy
    2013-12-05

    P.S. I also tried removing the .htaccess files with no change. PHP safe mode is off.

     
    • The error is 500 (internal server error) which is generated by the .htaccess. I don't think you deleted the right one.

       
      • It only happens in your plus folder (try this: http://testchat.aiiradio.net/plus/chat/) so you should delete the file plus/.htaccess which is the only in effect (not the ones with numbers).

         
  • Andy
    Andy
    2013-12-06

    I just removed all 3 htaccess files under http://testchat.aiiradio.net/plus/ and have the same result.

     
    • Please also check the permissions of the "plus" folder. It should be 755 not anything else (like 777 or other).
      If this doesn't fix it, please go into your main site cpanel (admin zone) and check the Error log. You should have there a short explanation of what's causing this error. Let me know.

       
  • Andy
    Andy
    2013-12-06

    The errors that appear are as follows:

    [Fri Dec 06 11:24:22 2013] [error] [client 79.254.124.190] PHP Warning: require(./localization//localized.chat.php): failed to open stream: No such file or directory in /var/www/vhosts/aiiradio.net/testchat/plus/lib/index.lib.php on line 103, referer: http://testchat.aiiradio.net/plus/chat/

    [Fri Dec 06 11:24:22 2013] [error] [client 79.254.124.190] PHP Warning: mysql_fetch_row() expects parameter 1 to be resource, boolean given in /var/www/vhosts/aiiradio.net/testchat/plus/config/config.lib.php on line 236, referer: http://testchat.aiiradio.net/plus/chat/

    [Fri Dec 06 11:13:54 2013] [error] [client 79.254.124.190] PHP Warning: date(): It is not safe to rely on the system's timezone settings. You are required to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Berlin' for 'CET/1.0/no DST' instead in /var/www/vhosts/aiiradio.net/testchat/plus/skins/style5.php on line 5, referer: http://testchat.aiiradio.net/plus/chat/

     
    • These warnings come up when the database connection fails. Can you open config/config.lib.php and check if the 4 lines of data are correct? Also make sure that the forth line (localhost) doesn't have another host address on your mysql server.

       
  • Andy
    Andy
    2013-12-06

    /testchat/ = 755
    /testchat/plus/ = 755
    /testchat/plus/config/ = 755
    /testchat/plus/config/config.lib.php = 644
    /testchat/plus/chat = 755

     
  • Andy
    Andy
    2013-12-06

    The 4 lines are correct and the same data was used to install with no error messages. If I change the 4th line to anything else, I receive a "Error: Could Not Connect To Database" message.

     
  • Andy
    Andy
    2013-12-06

    Also, if I try to enter the admin panel, I receive the following message after logging in:

    Database error: Invalid SQL: SELECT password,perms FROM c_reg_users WHERE username='admin' LIMIT 1
    MySQL error: 1146 (Table 'testchat.c_reg_users' doesn't exist)
    Session halted.

     
  • Andy
    Andy
    2013-12-06

    Problem found! Your install script did not create the tables while installing. I ran the SQL script and populated the database, and now I can see a login page.