Two days ago I created a small database with phpMyAdmin. Three simple tables, no more than 8 fields in each one. I manually entered some data, tried to apply foreign keys, but did not however succeed.

My problem is, when I came back to my database the following day, after my PC had been off all night, phpMyAdmin reported that no tables were found in the database.

I tried opening another database, and got an error 2003 'server is not responding'. Suggesting that something had screwed up MySQL or phpMyAdmin.

After much messing about, I eventually deleted the database via Windows Explorer and today I recreated the database and tables, and manually entered some data.

I switched off my PC, as I had an Optician's appointment, and now after switching back on find my database does not have any tables in it.


Any suggestions? Looking the directory in Windows Explorer I find four files:
db.opt
mag_contents.frm
mag_contents_authors.frm
mag_titles.frm

looking in other directories I find other files such as .MYD and .MYI should there be files with these endings in my directory also?

Looking in other directories I find some databases do not have a .MYD or .MYI and seem to work perfectly ok.

I really would appreciate some advice and maybe a solution.

phpMyAdmin version 3.2.2 rc1
mySQL ver  5.1
Apache 2.2


Suzanne Bradley.