#1424 Fallback for non-Javascript environments

Needs_decision
wont-fix
nobody
None
9
2013-11-28
2013-05-05
Cthulhux
No

So phpMyAdmin 4.0.0 "requires" Javascript.

Not well-thought Javascript is one of the most common security holes in current browsers, after Flash and Java, of course. As administering a DBMS is a security-related task, it should not be mandatory to enable Javascript.

phpMyAdmin should have a fallback option for this.

Until then, I (personally) will completely switch to Adminer.

Discussion

  • Marc Delisle
    Marc Delisle
    2013-05-05

    A bug is something that is intended to work but does not work. Since the beginning of the development of 4.0, we mentionned this new orientation of requiring Javascript, so IMO it's not a bug to require it.

    Moving to feature requests, although I don't believe we'll go this way.

     
  • Marc Delisle
    Marc Delisle
    2013-05-05

    Ticket moved from /p/phpmyadmin/bugs/3906/

     
  • Isaac Bennetch
    Isaac Bennetch
    2013-11-28

    • status: open --> wont-fix
    • Group: 4.0.0 --> Needs_decision