#1416 (ok 4.1) config.inc.php proxy settings for version_check.php

Needs_decision
fixed
None
1
2013-12-12
2013-03-30
David Ernstrom
No

The upgrade discussed at: https://github.com/phpmyadmin/phpmyadmin/pull/114 broke our ability to automatically check for updates on phpMyAdmin. The previous mechanism caused the update check to happen on the client computer, which utilized the browser proxy server if applicable. The new version assumes that the PHP server has unfettered internet access and moves the update check server-side. This is fine, except for when the server lives behind a proxy environment.

To address this new bug, it is suggested that optional parameters be added to the config.inc.php file to allow setting proxy server information in order to allow those requests to do an update-check. It is against our company policy to allow unfettered internet access from our servers, so globally setting proxy information at a server-level is not an option.

Discussion

    • assigned_to: Rouslan Placella
     
  • Marc Delisle
    Marc Delisle
    2013-05-14

    • summary: config.inc.php proxy settings for version_check.php --> (ok 4.1) config.inc.php proxy settings for version_check.php
    • status: open --> open-fixed
    • Priority: 5 --> 1
     
  • Michal Čihař
    Michal Čihař
    2013-06-11

    • Status: open-fixed --> resolved
     
  • Marc Delisle
    Marc Delisle
    2013-12-12

    • Status: resolved --> fixed