#782 (in 2.4.1) quotes conversion problem?

Latest_Git
fixed
1
2013-06-11
2003-03-09
Olivier Mueller
No

mysql 4, pretty standard table. This query works fine using
the command line mysql client:
DELETE FROM raw_pings WHERE hostname LIKE 'www.faz.de';

but if I try it via PMA, it asks

Voulez-vous vraiment effectuer :
DELETE FROM raw_pings WHERE hostname LIKE 'www.faz.de' ?

which is perfectely correct, but after if fails displaying:

requęte SQL :
DELETE FROM raw_pings WHERE hostname LIKE \ 'www.faz.de\'
MySQL a répondu:
You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near '\ 'www.faz.de\'' at line 1

It seems there is a problem somewhere... theses quotes _shouldn't_ be backslashed, and it adds a space at the wrong place (after LIKE, before the quote symbol). simple regexp problem? (magic_quotes_gpc=On, magic_quotes_runtime=Off )

Discussion

  • Garvin Hicking
    Garvin Hicking
    2003-03-10

    Logged In: YES
    user_id=473563

    Hi Olivier!

    This behaviour should be fixed since a couple of days in the
    actual CVS release. Can you try that? It works fine for me
    with the same magic_quotes setting.

    Regards,
    Garvin.

     
  • Garvin Hicking
    Garvin Hicking
    2003-03-10

    • status: open --> open-works-for-me
     
  • Logged In: YES
    user_id=15563

    Garvin: nope, I made a "cvs update" before... :)

    Seems that the problem is Opera-related: with other browsers (safari under osx or phoenix under linux) the confirmation is asked by a javascript popup and not an html page like under opera, and it works then. Under Opera the problem is still there. Strange: why no javascript popup then? Opera does support javascript... :)

     
  • Garvin Hicking
    Garvin Hicking
    2003-03-10

    • priority: 5 --> 1
    • assigned_to: nobody --> garvinhicking
    • summary: (2.4.x) quotes conversion problem? --> (in 2.4.1) quotes conversion problem?
    • status: open-works-for-me --> open-fixed
     
  • Garvin Hicking
    Garvin Hicking
    2003-03-10

    Logged In: YES
    user_id=473563

    Olivier: I'm sorry, you where absolutely right. The error only
    happened for non-JS browsers, and I normally don't use that.
    Nevertheless: Been there, saw the bug, killed it, got the T-
    Shirt.

     
    • status: open-fixed --> closed-fixed
     
  • Logged In: YES
    user_id=15563

    you're great, that is perfect customer support :-)
    grsse,
    Olivier

     
  • Michal Čihař
    Michal Čihař
    2013-06-11

    • Status: closed-fixed --> fixed