#690 (2.3.2) Database view empty with 1000+ tables

2.3.2
fixed
Interface (555)
1
2013-06-11
2002-12-08
Real Carbonneau
No

PHP 4.2.2
phpMyAdmin 2.3.2
MySQL 3.23.52
gzip 1.3.3

Browser: same problem with IE on Windows and
Mozilla on Linux.

For a database that contains 1000+ tables, the
database view script (db_details_structure.php) does
not return any data and as a result the right frame
windows remains empty.

For the left frame, it seems to correctly list all the
tables. It might be good to put a limit on how many
tables are listed and provide a next button.

Thanks in advance,
Real

Discussion

  • Marc Delisle
    Marc Delisle
    2002-12-08

    • summary: Database view empty when many tables --> Database view empty with 1000+ tables
     
  • Michal Čihař
    Michal Čihař
    2002-12-10

    Logged In: YES
    user_id=192186

    I have just created 1000 tables in db where some already
    were and I can't see any problem with
    db_details_structure.php. Yes it takes a bit longer to load,
    but it works...

    phpMyAdmin 2.3.4-dev
    MySQL 3.23.49
    PHP 4.2.1
    MSIE 6.0
    Apache 1.3.26

     
  • Michal Čihař
    Michal Čihař
    2002-12-10

    Logged In: YES
    user_id=192186

    Maybe the problem is in some php limits you have set, look
    into php.ini for these settings.

    I have:
    max_execution_time = 30
    memory_limit = 8M

     
  • Logged In: YES
    user_id=61368

    I do not receive an error message related to a timout or
    memory limit. I will attach the content of the index (as
    index.txt), left (as left.txt) and right (as
    db_details_structure.txt) frame. This is occuring after
    selecting the database in the left frame dropdown.
    Apache 2.0.40

     
  • index.txt

     
    Attachments
  • Michal Čihař
    Michal Čihař
    2002-12-10

    Logged In: YES
    user_id=192186

    All files you attached are indexes with framesets ;-)

     
  • Michal Čihař
    Michal Čihař
    2002-12-10

    • assigned_to: nobody --> nijel
     
  • Michal Čihař
    Michal Čihař
    2002-12-18

    • summary: Database view empty with 1000+ tables --> (2.3.2) Database view empty with 1000+ tables
     
  • Michal Čihař
    Michal Čihař
    2002-12-18

    Logged In: YES
    user_id=192186

    Could you please try to reproduce this with current cvs? I'm
    not able to do so... And output (if there is any) of
    db_details_structure.php would be also useful to know more
    about this.

     
  • Michal Čihař
    Michal Čihař
    2002-12-18

    • milestone: 258465 --> 2.3.2
     
  • Michal Čihař
    Michal Čihař
    2002-12-18

    Logged In: YES
    user_id=192186

    This problem doesn't appear for 1050 but did appear for 1150
    tables. If you turn output buffering off it will work....

     
  • Michal Čihař
    Michal Čihař
    2002-12-18

    • status: open --> open-invalid
     
  • Michal Čihař
    Michal Čihař
    2002-12-18

    • priority: 5 --> 1
     
  • Michal Čihař
    Michal Čihař
    2002-12-18

    Logged In: YES
    user_id=192186

    This seems to be php bug in php output buffering. I filled
    php bug, see http://bugs.php.net/21079 for details.

     
  • Michal Čihař
    Michal Čihař
    2003-01-26

    Logged In: YES
    user_id=192186

    With newer PHP it will work OK, I just tested it with
    PHP/4.5.0-dev (current CVS snapshot).

     
    • labels: --> 317619
    • status: open-invalid --> closed-accepted
     
    • labels: 317619 -->
     
    • status: closed-accepted --> closed-invalid
     
    • labels: --> Interface
    • status: closed-invalid --> open-invalid
     
    • status: open-invalid --> closed-accepted
     
  • Logged In: YES
    user_id=61368

    Ok, thanks.

     
  • Michal Čihař
    Michal Čihař
    2013-06-11

    • Status: closed-accepted --> fixed