#493 (in 2.5.0) Lost Relations /column comments

Latest_Git
fixed
1
2013-06-11
2002-07-09
mike valstar
No

ok,
first you need to create a table then relate it to another table

then change the name of foreign key field, then relate it
somewhere else or leave it, (i havent tryed this but it may also
happen if you delete a foreign key column)

ok now pull up a
pdf of your schema the old relation is still there but now it is pointing
from the primary key off the table that was altered.

the only
way to get rid of this is to find the row in the relations table and delete
it.

heh probly an extremely rare problem, but worth
fixing.

if i left anything out please email me.

Discussion

  • Mike Beck
    Mike Beck
    2002-07-12

    Logged In: YES
    user_id=509287

    hmm, i agree that we should check for that.. the only
    question is where and how to react... instead of deleting this
    entry i am rather thinking of stopping the execution and
    asking the user for action (name a new field, or delete this
    row....

     
  • Mike Beck
    Mike Beck
    2002-07-12

    • summary: PDF "lost" Relations --> PDF "lost" Relations
     
  • Mike Beck
    Mike Beck
    2002-07-12

    • priority: 5 --> 3
    • summary: PDF "lost" Relations --> PDF "lost" Relations
    • assigned_to: nobody --> mikebeck
     
  • mike valstar
    mike valstar
    2002-07-15

    Logged In: YES
    user_id=569602

    yeh that seems like a good idea you may want to add a list of "lost"
    relations to the bottom of the relation list, or at least somewhere on that
    page.

    and ,mayby add a check box on the display pdf part to
    show/not show lost relations.

    if i think of any more ideas i'll post
    them later.

     
  • mike valstar
    mike valstar
    2002-07-15

    • summary: PDF "lost" Relations --> PDF "lost" Relations
     
  • Mike Beck
    Mike Beck
    2002-07-23

    • summary: PDF "lost" Relations --> (2.3.1) PDF "lost" Relations
     
  • Mike Beck
    Mike Beck
    2002-07-23

    Logged In: YES
    user_id=509287

    i don't see an easy solution for this, so i would like to
    only work on this for 2.3.1 to not mess up anything right
    before we finally release 2.3.0.
    most of all i am not sure where to show any problems -
    showing it only on the page where you create the relations
    is not enough, as the user, once he set those up will not
    look at the page again. if the relation is still visible in
    the pdf but goes to nirvana that's fine with me as it should
    make the user realize by himself where the problem is...
    i should probably include some code that will alter
    relationsentries when the user renames or deletes a table,
    but still this will not be enough as the user might have
    deleted the table by hand.

     
  • mike valstar
    mike valstar
    2002-07-23

    • summary: (2.3.1) PDF "lost" Relations --> (2.3.1) PDF "lost" Relations
     
  • mike valstar
    mike valstar
    2002-07-23

    Logged In: YES
    user_id=569602

    ok i have another possible solution it you think this is plausable, you
    should put a link below create pdf that says something alog the lines of
    "check relation integraty" or something and have it list all relations that
    dont actually exist with the ability to delete them.

    i hope that one is
    possible

     
  • Marc Delisle
    Marc Delisle
    2002-07-25

    • summary: (2.3.1) PDF "lost" Relations --> (2.3.0-cvs) PDF "lost" Relations (-> 2.3.1)
     
  • Marc Delisle
    Marc Delisle
    2002-09-12

    • summary: (2.3.0-cvs) PDF "lost" Relations (-> 2.3.1) --> (2.3.0-cvs) PDF "lost" Relations
     
  • Marc Delisle
    Marc Delisle
    2003-01-18

    Logged In: YES
    user_id=210714

    In current phpMyAdmin, when the foreign table or foreign
    field have been renamed, if you go in Relation View of the
    master table, this link will be displayed in the format
    db.table.field instead of table->field.

    Would it be enough to add there some color (it works with
    "style" in Internet Explorer) and/or an added message ("not
    a key") next to it?

     
  • Marc Delisle
    Marc Delisle
    2003-01-18

    • summary: (2.3.0-cvs) PDF "lost" Relations --> (2.3.0-cvs) PDF "lost" Relations
     
  • Robin Johnson
    Robin Johnson
    2003-01-29

    • summary: (2.3.0-cvs) PDF "lost" Relations --> (2.3.0-cvs) PDF "lost" Relations
    • status: open --> open-later
     
  • Robin Johnson
    Robin Johnson
    2003-01-29

    Logged In: YES
    user_id=30201

    Thrashers idea of 'check relation integrity' is good, but I don't
    have time at the moment for it, i'll check into it for 2.4.1.

     
  • Marc Delisle
    Marc Delisle
    2003-02-16

    • summary: (2.3.0-cvs) PDF "lost" Relations --> (2.3.0-cvs) Lost Relations /column comments
     
  • Marc Delisle
    Marc Delisle
    2003-02-16

    Logged In: YES
    user_id=210714

    About column comments:
    1. Let's assume that there is a column named "ABC" in
    some table.
    2. Lets add some comment to this ("ABC") column.
    3. Then let's change name of this column from "ABC"
    to "CBA".
    4. Now the bug - there is no visible comment for newly
    named column "CBA", because old comment
    is "remembered" for column named "ABC".
    5. Altering back the name of column from "CBA"
    to "ABC" will affect returning the comment.

     
  • Garvin Hicking
    Garvin Hicking
    2003-03-05

    Logged In: YES
    user_id=473563

    I will try to work that up with the latest relational checks.

     
  • Garvin Hicking
    Garvin Hicking
    2003-03-05

    • labels: --> Relations,Comments,History,...
    • assigned_to: mikebeck --> garvinhicking
    • milestone: 218642 --> Latest_Git
     
  • Garvin Hicking
    Garvin Hicking
    2003-03-12

    • summary: (2.3.0-cvs) Lost Relations /column comments --> (in 2.4.1) Lost Relations /column comments
    • priority: 3 --> 1
    • status: open-later --> open-fixed
     
  • Garvin Hicking
    Garvin Hicking
    2003-03-12

    Logged In: YES
    user_id=473563

    Fixed in CVS.

     
  • Garvin Hicking
    Garvin Hicking
    2003-04-17

    • summary: (in 2.4.1) Lost Relations /column comments --> (in 2.5.0) Lost Relations /column comments
     
    • status: open-fixed --> closed-fixed
     
  • Michal Čihař
    Michal Čihař
    2013-06-11

    • Status: closed-fixed --> fixed