Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#4463 (ok 4.2.5) Fatal error: Class 'PMA_DatabaseInterface' not found (Validator.class.php on line 227)

4.2.3
fixed
None
1
2014-06-26
2014-06-18
Pierre Gasté
No

Hi,
When I go to :

Setup section > Overview > New server button > Configuration Storage

I add an user, a password and a database name (e.g. phpmyadmin) and I submit. I have this message :

Fatal error: Class 'PMA_DatabaseInterface' not found in /var/www/pma/libraries/config/Validator.class.php on line 227

After, from the overview section, I try to edit but I've got the same error.

Thanks for helping ;)

Discussion

  • Isaac Bennetch
    Isaac Bennetch
    2014-06-18

    Which phpMyAdmin version, please?

     
  • Pierre Gasté
    Pierre Gasté
    2014-06-18

    4.2.3, sorry :)

     
  • Isaac Bennetch
    Isaac Bennetch
    2014-06-18

    I see now that you did indicate that from the dropdown, my mistake :)

    Sorry for your trouble with this. I'm having trouble reproducing it, however. I'll do some more testing, but in the mean time, could you also tell us your PHP version? Is this a new install or an upgrade/reconfigure that replaces an existing phpMyAdmin installation?

     
  • Pierre Gasté
    Pierre Gasté
    2014-06-18

    PHP Version : 5.5.13

    It's a new install (from scratch) of phpMyAdmin :)

    When I add a simple include_once in the code (for the DatabaseInterface.class.php), it's working!

     
  • Hi,
    I can't reproduced it. Could you try to reinstall it please?
    Did you get the sources from GitHub, SourceForge? Another place?
    Thanks for your information.

     
  • Pierre Gasté
    Pierre Gasté
    2014-06-22

    Hi!
    I'm sorry but I don't remember where I downloaded it ...
    I'll try to reinstall it and I'll stay in touch!

    Thanks for your help :)

     
  • Pierre Gasté
    Pierre Gasté
    2014-06-22

    I just re-installed the 4.2.4 version (from SourceForge): same problem :(

    Small correction in the bug's description: The message appears only when I want to edit the server. No tab is available, the error is display each time.

    EDIT: I try to install phpMyAdmin 4.2.4 on my own Macbook: same error.

     
    Last edit: Pierre Gasté 2014-06-22
  • Thanks! I could reproduce the bug now!
    I'll fix this as soon as possible.

     
    • assigned_to: Hugues Peccatte
     
  • Marc Delisle
    Marc Delisle
    2014-06-23

    • summary: Fatal error: Class 'PMA_DatabaseInterface' not found (Validator.class.php on line 227) --> (ok 4.2.5) Fatal error: Class 'PMA_DatabaseInterface' not found (Validator.class.php on line 227)
    • status: open --> resolved
    • Priority: 6 --> 1
     
  • Marc Delisle
    Marc Delisle
    2014-06-26

    • Status: resolved --> fixed