#4405 (ok 4.2.4) Cannot import (open_basedir)

4.2.1
fixed
Marc Delisle
None
1
2014-06-23
2014-05-13
Marc Delisle
No

From Harald Reindl:

import.php: $tmp_subdir = sys_get_temp_dir();

4.2.0 complains about not writeable /tmp while the identical
server envirnoment worked before - no sane sever configuration
ever allows systems /tmp to be accessable on a shared server

define a temp-dir inside the phpMyAdmin tree or just
try try is_writable(ini_get('upload_tmp_dir')) and
store there whatever you want but the change in 4.2.0
is broken by design

i just did one change: $open_basedir = ''; because i need now
to import some dumps and even $tmp_subdir = DIR . '/tmp/';
while this directory exists, has write permissions and is for
sure in the open_basedir because otherwise phpMyAdmin could not
be loaded gives the same error with /usr/share/phpMyAdmin/tmp
instead just /tmp

skip the complete open_basedir check results in working as the
last 10 years ago - what i don't get is how someone assumes
system-temp is available for a webserver

Discussion

  • jirikmik
    jirikmik
    2014-05-20

    Same in 4.2.2. This check is really bad while sys_get_temp_dir() returns /tmp which is out of disk area for virtual web. I think it can be fixed by something as this in import.php, line 376:

    $tmp_subdir = sys_get_temp_dir();
    

    change to:

    $tmp_subdir = ini_get('upload_tmp_dir');
    
     
  • Marc Delisle
    Marc Delisle
    2014-05-28

    • assigned_to: Marc Delisle
     
  • Marc Delisle
    Marc Delisle
    2014-05-28

    • summary: Cannot import (open_basedir) --> (ok 4.2.3) Cannot import (open_basedir)
    • status: open --> resolved
    • Priority: 5 --> 1
     
  • Marc Delisle
    Marc Delisle
    2014-06-08

    • Status: resolved --> fixed
     
  • Marc Delisle
    Marc Delisle
    2014-06-11

    • summary: (ok 4.2.3) Cannot import (open_basedir) --> Cannot import (open_basedir)
    • status: fixed --> open
    • Priority: 1 --> 5
     
  • Marc Delisle
    Marc Delisle
    2014-06-13

    • summary: Cannot import (open_basedir) --> (ok 4.2.4) Cannot import (open_basedir)
    • status: open --> resolved
    • Priority: 5 --> 1
     
  • Marc Delisle
    Marc Delisle
    2014-06-23

    • status: resolved --> fixed