#4338 (ok 4.1.12) Executing queries in SQL tab broken

Latest_Git
fixed
None
1
2014-03-27
2014-03-24
Raimund Meyer
No
  1. Open the SQL tab in a database or table
  2. Enter some SQL in the textfield
  3. Hit OK
  4. Alert box says "Missing value in the form"

Discussion

  • Raimund Meyer
    Raimund Meyer
    2014-03-24

    Same with SQL box in the popup when you click "edit"

     
  • Hello Raimund,
    I think this happens when you omit the Delimiter, when writing the query in the box, in the end.

     
  • anr
    anr
    2014-03-24

    Apparently, the delimiter ";" given at the end of query worked

     
    Last edit: anr 2014-03-24
  • Marc Delisle
    Marc Delisle
    2014-03-24

    Raimund,
    I cannot reproduce with current master (f1b7735cc78067bc3ba0e350dc7b3d727947a41e).

     
  • Raimund Meyer
    Raimund Meyer
    2014-03-24

    It's positively in the latest master, see screenshot.
    anr seems to be right, it seems to be only when you don't have a ; at the end. On the other hand I could reproduce it with a normal dump

     
  • Marc Delisle
    Marc Delisle
    2014-03-24

    Raimund,
    it seems to happen only if I don't type anything in the box (executing the default query that appears there on entering). I can even cut&paste the default query, then it will work.
    Can you confirm?

     
  • Smita Kumari
    Smita Kumari
    2014-03-24

    Copy and pasting the below query don't work.. at least never worked for me.

    create table missing_val (
    id integer
    )

    Also if we add ';' or anything other than space in the end it works as the sqlQuery has some value other than space that is ';'.
    here is a pull request, I have submitted to fix the same, let me know if it looks fine.
    https://github.com/phpmyadmin/phpmyadmin/pull/1094

     
    Last edit: Smita Kumari 2014-03-24
  • Michal Čihař
    Michal Čihař
    2014-03-24

    • summary: Executing queries in SQL tab broken --> (ok 4.1.12) Executing queries in SQL tab broken
    • status: open --> resolved
    • assigned_to: Michal Čihař
    • Priority: 9 --> 1
     
  • Marc Delisle
    Marc Delisle
    2014-03-27

    • Status: resolved --> fixed