#3960 (ok 4.0.5) NavigationBarIconic config not honored

4.0.2
fixed
Marc Delisle
None
1
2013-08-04
2013-05-31
Pierre Paour
No

Whatever I set $cfg['NavigationBarIconic'] to, the top bar (right "panel") always uses icons only.

I tried setting this in config.inc.php and with the web interface, to no avail. This was fine in 4.0.1.

Discussion

  • Pierre Paour
    Pierre Paour
    2013-05-31

    I tried setting the PropertiesIconic with user preferences, and that changed the top bar. In other words, on my install the top bar and table operations respond to the same setting.

     
  • Marc Delisle
    Marc Delisle
    2013-06-01

    I think our problem is how these parameters are named and documented. IMO the current default behavior is acceptable, but it does not match the documentation nor the parameters names.

    And I don't think it would be appropriate to add parameters (for example, to control just how the navi icons/texts are displayed).

     
  • Isaac Bennetch
    Isaac Bennetch
    2013-06-02

    If I understand correctly, this is about the main page tabs (Databases, SQL, Status, etc) are affected by the same setting as the database- and table-level tabs (Structure or Browse, SQL, Search). Did I get that right?

     
  • Marc Delisle
    Marc Delisle
    2013-06-02

    Isaac,
    no, the server-level tabs are affected by the same parameter as the database- and table-level tabs. The PropertiesIconic parameter affects these tabs, but the documentation says that it should be NavigationBarIconic (even if the tabs are not the same as the navigation bar which contains the << < > >> buttons).

     
  • Marc Delisle
    Marc Delisle
    2013-06-06

    • summary: NavigationBarIconic config not honored --> (ok 4.0.4) NavigationBarIconic config not honored
    • status: open --> open-fixed
    • Priority: 5 --> 1
     
  • Michal Čihař
    Michal Čihař
    2013-06-11

    • Status: open-fixed --> resolved
     
  • Marc Delisle
    Marc Delisle
    2013-06-17

    • Status: resolved --> fixed
     
  • Can you clear up something as I am confused. Are you saying that there is now no way to have the navigation bar use text+icons but have the tables use icons only?

    If so, this feels like a big misstep to me - the table icons are very obvious common icons that are used in many apps (edit/delete etc), whereas the icons on the nav bar are not. Plus the fact there are many of them and they are not very big. It's impossible to know at a glance which is which.

     
    • Pierre Paour
      Pierre Paour
      2013-06-18

      I have to agree, this feels like a regression in terms of usability.

       
  • Marc Delisle
    Marc Delisle
    2013-06-18

    When you guys are talking about the navigation bar, what do you mean?

    For me, the navigation bar does not mean the top menu bar; it means the bar that permits to navigate in a results set and contains the page number selector, arrows for next and previous pages, etc.

     
  • Pierre Paour
    Pierre Paour
    2013-06-18

    I think we're on the same page: nav bar is the part of the screen previously known as the nav frame + pagination; Table operations refers to the actions that can be performed on the browse and structure views.

    It used to be that the top menu bar was independent of the table operation icon settings, so that we could use pure icon table operations, yet retain text labels for the top menu bar (and the settings bars, whose icons are even less intuitive).

    In 4.0.2 the menu bar and table operations were fused, and that's our problem: we need text labels for menus, and we would rather stick with icons for table operations (much less wasted space).

    Here are a few screenshots to illustrate: https://www.dropbox.com/sh/3mviyl2roqaqgda/MACyjjyHmC

    As a bonus, using Navigation Bar: No results in artefacts in the nav bar.

     
  • Marc Delisle
    Marc Delisle
    2013-06-18

    Thanks for your screenshots. We were not talking about the same thing at all. You were talking about the top icons in the navigation panel and I was talking about the bar that permits to navigate in the results set.

    Working on this.

     
  • Marc Delisle
    Marc Delisle
    2013-06-18

    • summary: (ok 4.0.4) NavigationBarIconic config not honored --> NavigationBarIconic config not honored
    • status: fixed --> open
    • Priority: 1 --> 5
     
  • Marc Delisle
    Marc Delisle
    2013-06-18

    I think we will have to add a configuration directive to control only the behavior of the menu tabs. Sounds good?

     
    • Yep, sounds good.

       
  • Sorry if I wasn't clear. I was talking about the top menu bar in the main panel, the one that goes Browse/Structure/SQL/Import/Export when on a table view.

    I am setting $cfg['PropertiesIconic']=true; in order to only show icons for the Edit/Copy/Delete icons that are by every row of a table. But that is also setting the top menu bar to be icons only.

    To me it doesn't make sense for that top one to be icons only, for reasons stated above. Another reason is that the same icon does different things in different places. For example the cylinder icon is "Databases" when on the root page (aka "localhost"), but on a db page (localhost > databasename) it is "Query".

    There is also some confusion with the names. The "NavigationBarIconic" option is applying to the navigation at the top of the left panel. Is this the intended behaviour? Those icons are more obvious and consistent across the app so I think they are fine to stay as icons only (the layout is awkward when icons+text is used). My preference is:

    • Left panel, top navigation: icons only.
    • Main panel, top menu bar: icons and text.
    • Main panel, table of query results: icons only.
    • Main panel, table navigation bar: [AFAIK this is not customisable, it's just text only]
     
  • Marc Delisle
    Marc Delisle
    2013-06-24

    • summary: NavigationBarIconic config not honored --> (ok 4.0.5) NavigationBarIconic config not honored
    • status: open --> resolved
    • Priority: 5 --> 1
     
  • candev
    candev
    2013-07-13

    I'm testing 4.0.4.1. Previously the display of the menu tabs in the main panel has been conttrolled by NavigationBarIconic found in the Settings|Main panel|Browse mode tab. Now this setting seems to control the top buttons in the navigation panel even though it is under Main panel settings. Should the navigation panel icons option be somewhere under Settings|Navigation panel and make NavigationBarIconic work as previously?

     
  • candev
    candev
    2013-07-14

    OK. The demo looks really good. I originally found this ticket in the phpMyAdmin Changelog under section 4.0.4.0, so I thought it was fixed already. Only after I read the whole ticket, did I realise the fix is for 4.0.5. Thanks.

     
  • Marc Delisle
    Marc Delisle
    2013-08-04

    • Status: resolved --> fixed