Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#3860 Displayed git revision info is not set

Latest_Git
open
None
Normal
2015-02-15
2013-03-26
Marcus Bointon
No

On the PHPMyAdmin home page after logging in, it shows the git revision branch, date and user, but they are not set after I've checked out the code from git. Screen shot attached.

1 Attachments

Discussion

  • Marc Delisle
    Marc Delisle
    2013-03-29

    On which branch is set your repository (the output of "git status")?

     
  • Marc Delisle
    Marc Delisle
    2013-03-29

    • assigned_to: Marc Delisle
     
  • Marcus Bointon
    Marcus Bointon
    2013-03-29

    It's on 'master', but of my own github fork (currently has no changes relative to upstream repo).

     
  • Marc Delisle
    Marc Delisle
    2013-03-29

    I don't see the reason. Sorry, this does not have an impact on our users, closing for now.

     
  • Marc Delisle
    Marc Delisle
    2013-03-29

    • status: open --> closed-wont-fix
     
  • Michal Čihař
    Michal Čihař
    2013-04-11

    • summary: Displayed git revision info is not set --> (ok 4.0) Displayed git revision info is not set
    • status: closed-wont-fix --> closed-fixed
    • assigned_to: Marc Delisle --> Michal Čihař
    • Priority: 5 --> 1
     
  • Michal Čihař
    Michal Čihař
    2013-04-11

    • status: closed-fixed --> open-fixed
     
  • Ann + J.M.
    Ann + J.M.
    2013-04-27

    • summary: (ok 4.0) Displayed git revision info is not set --> Displayed git revision info is not set
     
  • Ann + J.M.
    Ann + J.M.
    2013-04-27

    • status: open-fixed --> open
    • Priority: 1 --> 2
     
  • Ann + J.M.
    Ann + J.M.
    2013-04-27

    This bug still appears randomly for me, will try to keep track when it does.

     
  • Ann + J.M.
    Ann + J.M.
    2013-05-01

    @nijel Please download the following file to your webserver:

    bug-gitfolder.tar.gz (283.4 MB)

    Then untar it to a blank folder (.git folder is created), then run git checkout master --force. In that PMA instance, you'll be able to reproduce the bug.

     
    Last edit: Ann + J.M. 2013-05-01
  • Marc Delisle
    Marc Delisle
    2015-02-15

    • Priority: 2 --> Normal