#3855 (ok 4.0) IE10 Blank screen issue

3.5.7
fixed
Marc Delisle
None
1
2013-06-11
2013-03-23
Ken
No

When I click a table name (or any of the action tabs), the right pane always show up as a blank screen.

This issue started after installing Internet Explorer 10.

The only way to solve it is to refresh the page.

Discussion

1 2 3 .. 7 > >> (Page 1 of 7)
  • JulienTLD
    JulienTLD
    2013-03-25

    I have the same blank pages problem with PMA 3.5.5 and 3.5.7 after installing Internet Explorer 10 under Windows 7 x64. No problems with IE9 or Firefox. Please, post a fix ;)

    PHP 5.4.12 and 5.4.13
    MySQL 5.5.30
    IIS 8.0

     
    Last edit: JulienTLD 2013-03-25
  • Marc Delisle
    Marc Delisle
    2013-03-25

    Cannot reproduce this problem with phpMyAdmin 3.5.7. Testing on Windows 7 x64, Internet Explorer 10.0.9200.16521.

    Can you produce the problem when accessing http://demo.phpmyadmin.net/STABLE ? (user root, no password)

     
  • Marc Delisle
    Marc Delisle
    2013-03-25

    • assigned_to: Marc Delisle
     
  • Marc Delisle
    Marc Delisle
    2013-03-25

    • status: open --> pending-works-for-me
     
  • JulienTLD
    JulienTLD
    2013-03-25

    Hello Marc,

    Can't reproduce the problem with your demo PMA.

    Same IE10 version than you. Default IE security settings. No IE plugin installed except Adobe Shockwave/Flash, Apple QuickTime and Microsoft Silverlight.

    On the server side, I run IIS 8.0, FastCGI, PHP 5.4.13, MySQL 5.5.30 (mysqli), PMA config auth.

    How can we debug this?

     
  • Ken
    Ken
    2013-03-25

    Demo PMA works for me.

    I'm using Internet Explorer 10.0.9200.16521

    Loaded addons : Shockwave Flash, DivX Web Player, Java(tm).

     
  • Marc Delisle
    Marc Delisle
    2013-03-25

    @JulienTLD: any error in your IIS error log?

    @Ken: are you on IIS too? (I am running Apache and the demo site is running lighttpd)

     
  • Ken
    Ken
    2013-03-25

    Sorry Marc, forgot to post the specs.

    Nginx 1.2.7, Apache 2.2.24, PHP 5.3.23, MySQL 5.1.68 (mysqli)

    Nginx handles all incoming connections, PHP is passed off to Apache.

     
    Last edit: Ken 2013-03-25
  • Marc Delisle
    Marc Delisle
    2013-03-25

    Ken, anything relevant in the Nginx or Apache error log?

    My IE has Shockwave Flash Object, Adobe PDF Link Helper, Office Document Cache Handler, Java Plug-In SSV Helper and Java Plug-In 2 SSV Helper.

     
  • JulienTLD
    JulienTLD
    2013-03-25

    A click on a table name on the left frame gives me in IIS logs:

    2013-03-25 17:27:09 10.0.0.1 GET /sql.php db=database&token=9f1778d339312e14ca63ea5e0a013b8d&table=table&pos=0 80 SERVER\admin my_ip Mozilla/5.0+(compatible;+MSIE+10.0;+Windows+NT+6.1;+WOW64;+Trident/6.0) http://domain.com/navigation.php?token=9f1778d339312e14ca63ea5e0a013b8d&db=database 200 0 0 359

    2013-03-25 17:27:09 10.0.0.1 GET /navigation.php token=9f1778d339312e14ca63ea5e0a013b8d&server=1&ajax_request=true&recent_table=true&_nocache=1364232416671225572 80 SERVER\admin my_ip Mozilla/5.0+(compatible;+MSIE+10.0;+Windows+NT+6.1;+WOW64;+Trident/6.0) http://domain.com/navigation.php?token=9f1778d339312e14ca63ea5e0a013b8d&db=database 200 0 0 406

    No errors, just 200 HTTP codes but right frame is white.

     
    Last edit: JulienTLD 2013-03-25
1 2 3 .. 7 > >> (Page 1 of 7)