Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#3713 (ok 4.0) Truncate table does not work

Latest_Git
fixed
AJAX (99)
1
2013-06-11
2012-11-02
Benjam
No

When trying to truncate a table via the "Operations" tab -> "Empty the table" link, the script takes me to the confirmation page, where I click "Yes". and nothing happens, it just reloads the confirmation page.

Truncating a table via the "SQL" tab works fine.

Discussion

  • Marc Delisle
    Marc Delisle
    2012-11-03

    Trying with latest git (0a30c682dca4fcf06899a1f111f2fdac08a25406), I cannot reproduce this bug.

     
  • Marc Delisle
    Marc Delisle
    2012-11-03

    • status: open --> pending-works-for-me
     
  • I haven't imported the list of bugs from the frames-removal branch into the tracker yet, but this is one of them.
    The issue exists if you set $cfg['EnableAjax'] to false and is applicable to all confirmation messages that are generated by sql.php

    Since we will be dropping the $cfg['EnableAjax'] directive for pma 4.0, this particular bug is probably not that important, but it should be investigated where other confirmation messages that are generated by sql.php are used.

     
    • labels: --> AJAX
    • status: pending-works-for-me --> open
     
    • summary: Truncate table does not work --> (ok 4.0) Truncate table does not work
    • priority: 5 --> 1
    • assigned_to: nobody --> roccivic
    • status: open --> closed-fixed
     
  • This bug was fixed in repository and will be part of a future release; thanks for reporting.

     
  • Michal Čihař
    Michal Čihař
    2013-06-11

    • Status: closed-fixed --> fixed