#3668 (ok 3.5.3) current_date from function drop down fails update

3.5.2
fixed
1
2013-06-11
2012-08-20
Anonymous
No

phpMyAdmin Version information: 3.5.2
MySQL: 5.1.61
PHP: 5.3.3
Server: RHEL 5

When directly editing a row via the edit page (AJAX disabled), I am unable to update a DATE column by selecting "CURRENT_DATE" from the functions drop down list. The issue is that if there is already a value in the field the SQL query is sent as:

> UPDATE `table` SET `date` = CURRENT_DATE( '2012-08-17' ) WHERE `id` = 1

If I attempt to update with no value in the DATE column the SQL query will be as follows:

> UPDATE `table` SET `date` = CURRENT_DATE( '' ) WHERE `id` = 1

Which also fails because CURRENT_DATE( '' ) is not proper MySQL syntax.

In phpMyAdmin 2.* under MySQL 4.1.22 this was not an issue, phpMyAdmin would send CURDATE() regardless of the value in the input field for the DATE column.

Thank you,
Lucas

Discussion

    • assigned_to: nobody --> madhuracj
     
    • priority: 5 --> 1
    • summary: current_date from function drop down fails on update --> (ok 3.5.3) current_date from function drop down fails update
    • status: open --> open-fixed
     
  • This bug was fixed in repository and will be part of a future release; thanks for reporting.

     
  • Marc Delisle
    Marc Delisle
    2012-10-08

    • status: open-fixed --> closed-fixed
     
  • Michal Čihař
    Michal Čihař
    2013-06-11

    • Status: closed-fixed --> fixed