#3643 Bug with search and PHP 5.4

3.5.2
fixed
nobody
Interface (555)
5
2013-06-11
2012-07-18
JulienTLD
No

Hello,

Server = MySQL 5.5.25 + Windows Server 2003 + IIS 6.0 + PHP 5.4.4 + FastCGI 1.5

Since I have updated PHP 5.3 to PHP 5.4, I have a bug with PHPMyAdmin 3.4 and 3.5 versions.
On a specific table, when I do a search on a column with the PMA interface, I do not obtain the result page but I stay on the form page and the top of the page is duplicated (the top band "Display / Structure /SQL/Search/......").

I do not have this problem if I search with a SQL query.
I do not have this problem with PHP 5.3 + PMA 3.4 or 3.5.
I do not have this problem with PHP 5.4 + PMA 3.2.
I have the same problem on an other IIS 7.0 server with the same database

For investigating, I have truncated the whole content of the table and I have just added one row. Yet impossible to do a search.
I have then deleted the text colums type and I obtain now an SQL error signaling a syntax error (the ORDERBY command is empty) :

SELECT (liste of columns.....)
FROM`membres`
WHERE`pseudo`LIKE'Julien'
ORDERBY
LIMIT 0 , 30

I have then deleted an other column (a classic VARCHAR column) and the search works well now !

Very strange ! Any idea why the ORDERBY is empty ?

Discussion

  • JulienTLD
    JulienTLD
    2012-07-18

     
    Attachments
  • Marc Delisle
    Marc Delisle
    2012-07-18

    • status: open --> pending
     
  • Marc Delisle
    Marc Delisle
    2012-07-18

    Please attach an export in SQL format of your table's structure, merci.

     
  • JulienTLD
    JulienTLD
    2012-07-18

     
    Attachments
  • JulienTLD
    JulienTLD
    2012-07-18

    Thanks lem9 for your answer. The table structure is attached.

     
  • JulienTLD
    JulienTLD
    2012-07-18

    • status: pending --> open
     
  • Marc Delisle
    Marc Delisle
    2012-07-19

    I tested on a Linux server (Apache 2.2.22, PHP 5.4.4, MySQL 5.6.4, phpMyAdmin 3.5.2) and could not reproduce your problem. I was able to do a search on pseudo 'Julien' and get the answer.

    I hope you are using the mysqli extension.
    Are you using mysqlnd?
    Any error in the web server log files?

     
  • JulienTLD
    JulienTLD
    2012-07-19

    Yes, I use mysqli and mysqlnd. No error in the IIS log file nor PHP log file.

    Do you think it's could be a charset problem ?

    I have this problem since I have migrated to PHP 5.4 and it uses now UTF-8 in core. On my server, MySQL server/client, MySQL tables, PMA and PHP (.ini) are set to use the ISO-8859-1 charset.

     
  • Marc Delisle
    Marc Delisle
    2012-07-19

    Maybe. Please attach your phpMyAdmin config.inc.php file, obfuscating sensitive details, and your php.ini file.I'll try to reproduce the problem on Apache.

     
  • Marc Delisle
    Marc Delisle
    2012-07-19

    • status: open --> pending
     
  • JulienTLD
    JulienTLD
    2012-07-19

     
    Attachments
  • JulienTLD
    JulienTLD
    2012-07-19

     
    Attachments
  • JulienTLD
    JulienTLD
    2012-07-19

    These two files are attached. Thanks.

     
  • JulienTLD
    JulienTLD
    2012-07-19

    • status: pending --> open
     
  • Marc Delisle
    Marc Delisle
    2012-07-21

    • status: open --> pending
     
  • Marc Delisle
    Marc Delisle
    2012-07-21

    Thanks. Is it an option for you to not be set to use ISO-8859-1? At least you could give it a try to see if this is the cause of your problem?

     
  • JulienTLD
    JulienTLD
    2012-10-09

    Hello lem9,

    I have just upgraded PMA from 3.5.2.2 to 3.5.3.0 and I do not see more the bug with the searches and the interface. I do not know which fix in the ChangeLog list has solved my bug (perhaps 3539044 ?) but it is a very good news !

    Thanks

     
  • JulienTLD
    JulienTLD
    2012-10-09

    • status: pending --> open
     
  • Marc Delisle
    Marc Delisle
    2012-10-09

    • status: open --> closed
     
  • Marc Delisle
    Marc Delisle
    2012-10-09

    Thanks for the feedback; closing.

     
  • Michal Čihař
    Michal Čihař
    2013-06-11

    • Status: closed --> fixed