Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#3643 Bug with search and PHP 5.4

3.5.2
fixed
nobody
Interface (554)
5
2013-06-11
2012-07-18
JulienTLD
No

Hello,

Server = MySQL 5.5.25 + Windows Server 2003 + IIS 6.0 + PHP 5.4.4 + FastCGI 1.5

Since I have updated PHP 5.3 to PHP 5.4, I have a bug with PHPMyAdmin 3.4 and 3.5 versions.
On a specific table, when I do a search on a column with the PMA interface, I do not obtain the result page but I stay on the form page and the top of the page is duplicated (the top band "Display / Structure /SQL/Search/......").

I do not have this problem if I search with a SQL query.
I do not have this problem with PHP 5.3 + PMA 3.4 or 3.5.
I do not have this problem with PHP 5.4 + PMA 3.2.
I have the same problem on an other IIS 7.0 server with the same database

For investigating, I have truncated the whole content of the table and I have just added one row. Yet impossible to do a search.
I have then deleted the text colums type and I obtain now an SQL error signaling a syntax error (the ORDERBY command is empty) :

SELECT (liste of columns.....)
FROM`membres`
WHERE`pseudo`LIKE'Julien'
ORDERBY
LIMIT 0 , 30

I have then deleted an other column (a classic VARCHAR column) and the search works well now !

Very strange ! Any idea why the ORDERBY is empty ?

Discussion

<< < 1 2 3 > >> (Page 2 of 3)
  • JulienTLD
    JulienTLD
    2012-07-19

     
    Attachments
  • JulienTLD
    JulienTLD
    2012-07-19

     
    Attachments
  • JulienTLD
    JulienTLD
    2012-07-19

    These two files are attached. Thanks.

     
  • JulienTLD
    JulienTLD
    2012-07-19

    • status: pending --> open
     
  • Marc Delisle
    Marc Delisle
    2012-07-21

    • status: open --> pending
     
  • Marc Delisle
    Marc Delisle
    2012-07-21

    Thanks. Is it an option for you to not be set to use ISO-8859-1? At least you could give it a try to see if this is the cause of your problem?

     
  • JulienTLD
    JulienTLD
    2012-10-09

    Hello lem9,

    I have just upgraded PMA from 3.5.2.2 to 3.5.3.0 and I do not see more the bug with the searches and the interface. I do not know which fix in the ChangeLog list has solved my bug (perhaps 3539044 ?) but it is a very good news !

    Thanks

     
  • JulienTLD
    JulienTLD
    2012-10-09

    • status: pending --> open
     
  • Marc Delisle
    Marc Delisle
    2012-10-09

    • status: open --> closed
     
  • Marc Delisle
    Marc Delisle
    2012-10-09

    Thanks for the feedback; closing.

     
<< < 1 2 3 > >> (Page 2 of 3)