Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#3615 Insert field functions replaced with "Binary" text

Latest_Git_snapshot
fixed
Marc Delisle
Interface (555)
5
2013-06-11
2012-06-19
Benjam
No

When I try to insert a new row into a table using the "Insert" tab, the place where the function select dropdown is usually located has been replaced with the word "Binary". Not sure what this means, but I miss my functions.

Apache/2.4.1 (Win32) PHP/5.4.0
5.5.22 - MySQL Community Server (GPL)

Discussion

  • Marc Delisle
    Marc Delisle
    2012-06-19

    I cannot reproduce (but I'm not running PHP 5.4.0 at the moment). Could you give the exact git revision (can usually be seen on the main page) ?

    Attach also a screenshot.

     
  • Marc Delisle
    Marc Delisle
    2012-06-19

    • status: open --> pending
     
  • Benjam
    Benjam
    2012-06-19

    • status: pending --> open
     
  • Benjam
    Benjam
    2012-06-19

    I'm not sure what version info you were referring to, so I screen-capped the version info area of the main page.

    I did grab the latest nightly "phpMyAdmin-master-latest.zip" from the website just before I submitted this bug to see if it had been fixed. So it's up to date as of yesterday.

    I'll look into it a bit more and see if I can't track anything down.

     
  • Benjam
    Benjam
    2012-06-19

    So after looking into it, it seems I may have found the cause...

    In ../libraries/insert_edit.lib.php in the `PMA_getFunctionColumn` function, there is an IF statement near the top of the function that is testing various settings. The statement that is failing for me is the following:

    ($GLOBALS['cfg']['ProtectBinary'] == 'noblob' && !$column['is_blob'])

    The trouble with it is that my $GLOBALS['cfg']['ProtectBinary'] variable is set to (INT) 0, which equates to TRUE when doing a loose comparison with 'noblob'. Then because my column is not a BLOB column, the $column['is_blob'] is FALSE, which when negated, equates to TRUE.

    The whole thing then equals TRUE, and the output is 'Binary'.

    The way to fix this issue is to use the strict comparison (===) test instead of the loose comparison (==) test for the two string comparisons ("all" & "noblob").

     
  • Marc Delisle
    Marc Delisle
    2012-06-20

    • assigned_to: nobody --> lem9
     
  • Marc Delisle
    Marc Delisle
    2012-06-20

    • status: open --> closed-fixed
     
  • Marc Delisle
    Marc Delisle
    2012-06-20

    Fixed in master, thanks for reporting.

     
  • Michal Čihař
    Michal Čihař
    2013-06-11

    • Status: closed-fixed --> fixed