Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#3580 (ok 3.5.2) Fatal error: Call to undefined function __()

3.5.0
fixed
Marc Delisle
1
2013-06-11
2012-04-25
Dani Düsentrieb
No

The error messages from the file Coinfig.class.php call a function from the not exists in this file. At line 727 of file is the following code:

sprintf (__ ('Existing configuration file (% s) is not readable.')
$ this-> getSource ()
)

The function __ () does not exist.

Discussion

  • Marc Delisle
    Marc Delisle
    2012-04-25

    There is no space in the source code between __ and (. So the problem is not that the function __ () does not exist, it's probably that the function__() (without a space) does not exist at calling time.

     
  • Yes that's right, my mistake. Nevertheless, it comes with the device from phpmyadmin to this error message because the function exists in the class. If then the function must be called from any but a class and even then the call is wrong. Only when I removed the device from the phpmyadmin in the file the function call, the device was un usual, the actual error message was displayed. The Quelllcode of my EXEMPLE looks like this.

    sprintf ('Existing configuration file (% s) is not readable.'
    $ this-> getSource ()
    )

     
  • Marc Delisle
    Marc Delisle
    2012-04-27

    • assigned_to: nobody --> lem9
     
  • Marc Delisle
    Marc Delisle
    2012-04-27

    This bug was fixed in repository and will be part of a future release; thanks for reporting.

     
  • Marc Delisle
    Marc Delisle
    2012-04-27

    • priority: 5 --> 1
    • summary: Fatal error: Call to undefined function () in /volume1/web --> (ok 3.5.2) Fatal error: Call to undefined function ()
    • status: open --> open-fixed
     
  • Marc Delisle
    Marc Delisle
    2012-07-20

    • status: open-fixed --> closed-fixed
     
  • Michal Čihař
    Michal Čihař
    2013-06-11

    • Status: closed-fixed --> fixed