#3565 Structure window -> "drop" link

3.5.0
invalid
nobody
AJAX (99)
2
2013-06-11
2012-04-14
Anonymous
No

Open separate table structure.
Select column, click Drop.

Uncaught TypeError: Cannot call method 'replace' of undefined
event.layerX and event.layerY are broken and deprecated in WebKit. They will be removed from the engine in the near future.

Functions.js : line 118

CHROME

---
Btw. nice fucking idea to use JQuery!! Yes, irony!

Discussion

  • Marc Delisle
    Marc Delisle
    2012-04-14

    I guess it's easy to criticize when you're anonymous but at least, give some technical points to back your affirmation.

    And what to you mean by "open separate table structure" ?

     
  • I think that the rude man means to open only the main frame containing the table structure page, without the navigation frame that is.

    I'm getting a different error in this scenario (Firefox 11):

    unsafe is undefined
    http://localhost/pma/js/functions.js?ts=1334411088
    Line 3437

     
  • Michal Čihař
    Michal Čihař
    2012-04-18

    The problem is in following line in js/tbl_structure.js:

    var curr_table_name = window.parent.table;

    Obviously when the table structure is opened separately, window parent does not exist.

     
  • Ann + J.M.
    Ann + J.M.
    2012-07-01

    • priority: 5 --> 2
    • status: open --> pending-invalid
     
  • Ann + J.M.
    Ann + J.M.
    2012-07-01

    The table structure page is not meant to be opened separately, outside of the frameset. This issue will solve itself after the frames-removal.

     
  • Marc Delisle
    Marc Delisle
    2013-01-18

    • status: pending-invalid --> closed-invalid
     
  • Michal Čihař
    Michal Čihař
    2013-06-11

    • Status: closed-invalid --> invalid