#3496 (ok 3.5.0-beta1)cannot press enter on the VARIABLE field

3.4.8
fixed
Marc Delisle
1
2013-06-11
2011-12-23
Anonymous
No

if I press enter after typing a value in the VARIABLE field of a bookmarked query, it's the query displayed above which is executed, not the bookmarked one

Discussion

  • Marc Delisle
    Marc Delisle
    2011-12-28

    • status: open --> pending
     
  • Marc Delisle
    Marc Delisle
    2011-12-28

    Please indicate which phpMyAdmin version in "Group".

     

  • Anonymous
    2011-12-28

    • milestone: --> 3.4.8
    • status: pending --> open
     
  • Marc Delisle
    Marc Delisle
    2011-12-29

    • assigned_to: nobody --> lem9
     
  • Marc Delisle
    Marc Delisle
    2011-12-29

    • assigned_to: lem9 --> nobody
     
  • Alex Marin
    Alex Marin
    2012-01-23

    I can confirm this in 3.4.9. The problem seems to be that when you "press enter after typing a value in the VARIABLE field of a bookmarked query", the button in the "Run SQL query/queries on database $db" ( #button_submit_query ) is triggered instead of #button_submit_bookmark in the "Bookmarked SQL query" section. That happens because button_submit_query has a tabindex="200" defined, whereas #button_submit_bookmark does not.

     
  • Marc Delisle
    Marc Delisle
    2012-01-23

    • priority: 5 --> 1
    • assigned_to: nobody --> lem9
    • summary: cannot press enter on the VARIABLE field of a bookmark --> (ok 3.5.0-beta1)cannot press enter on the VARIABLE field
    • status: open --> open-fixed
     
  • Marc Delisle
    Marc Delisle
    2012-04-07

    • status: open-fixed --> closed-fixed
     
  • Michal Čihař
    Michal Čihař
    2013-06-11

    • Status: closed-fixed --> fixed