#3427 Error messages are displayed using wrong codetable.

3.4.7
out-of-date
Marc Delisle
3
2013-06-11
2011-09-13
No

1. Create test database:

CREATE TABLE `test` (
`data` varchar(64) CHARACTER SET utf8 NOT NULL,
UNIQUE KEY `data` (`data`)
)

2. Add test data.

INSERT INTO `test`.`test` (`data`) VALUES ('абв');

3. Issue the same statement again:

INSERT INTO `test`.`test` (`data`) VALUES ('абв');

4. Receive error:

#1062 - Duplicate entry 'абв' for key 'data'

Ecxpected:

#1062 - Duplicate entry 'абв' for key 'data'

Discussion

    • labels: --> Displaying results
    • priority: 5 --> 3
     
  • P.S. This problem is applicable for all error messages, not only the ones that you receive by submitting the statement using the SQL tab.

     
  • Marc Delisle
    Marc Delisle
    2011-09-24

    • assigned_to: nobody --> lem9
    • status: open --> pending
     
  • Marc Delisle
    Marc Delisle
    2011-09-24

    Cannot reproduce in 3.4.4.

    Which language did you choose on the main page?
    Which SQL textarea are you using to enter your queries.
    Which browser, PHP and MySQL versions?

     
  • Just reproduced again

    phpMyAdmin Version information: 3.4.7.1
    Appearance Settings/Language: English (no other languages available in the dropdown anyway)

    Server version: 5.1.58
    Protocol version: 10
    MySQL charset: UTF-8 Unicode (utf8)

    Firefox 8.0 (English), "View-> Character Encoding -> Unicode (UTF-8)"

     
    • milestone: 2093163 --> 3.4.7
    • status: pending --> open
     
  • Marc Delisle
    Marc Delisle
    2011-11-23

    • status: open --> pending
     
  • Marc Delisle
    Marc Delisle
    2011-11-23

    I was trying to reproduce with a MySQL 5.5.13 server and could not, but I can reproduce with a MySQL 5.1.55 server.

    I'm using PHP 5.3.8 + mysqlnd client.

    I suspect it's a MySQL 5.1 bug, do you agree?

     
  • Marc Delisle
    Marc Delisle
    2013-01-18

    • status: pending --> closed-out-of-date
     
  • Michal Čihař
    Michal Čihař
    2013-06-11

    • Status: closed-out-of-date --> out-of-date