#3412 (ok 3.4.9)No feedback when result is empty, signon auth_type

3.4.8
fixed
Marc Delisle
1
2013-06-11
2011-08-26
pb30
No

1. Select a database and a table within that database
2. Click the SQL tab
3. Run a valid SQL query that will return no results (SELECT * FROM table WHERE id=99999)
4. Notice 'Loading' message is displayed, then fades out with no indication if there was an error or if the query was successful. JSON response displays 'empty result set' message, but nothing is displayed on screen.

OSX 10.7 / Safari 5.1
phpMyAdmin 3.4.4
MySQL client version: 5.0.51a
MySQL Server version: 5.1.49-3

Discussion

  • Works for me...
    Can you reproduce this issue on our demo server (http://demo.phpmyadmin.net/) ?

     
    • status: open --> pending
     
  • pb30
    pb30
    2011-09-16

    • status: pending --> open
     
  • pb30
    pb30
    2011-09-16

    I'm unable to reproduce it on the demo server, however I tried setting up a clean install of 3.4.5 and was able to replicate it only when the authtype of the server is set to 'signon'. Changing it to 'cookie' works fine (however we're using 'signon' to do some LDAP integration and need to keep it). The signon code is basically the same as the code on http://wiki.phpmyadmin.net/pma/Auth_types#signon

    Config is:
    <?php
    /* Servers configuration */
    $i = 0;

    $i++;
    $cfg['Servers'][$i]['host'] = 'mysqlserver.net';
    $cfg['Servers'][$i]['port'] = '';
    $cfg['Servers'][$i]['socket'] = '';
    $cfg['Servers'][$i]['connect_type'] = 'tcp';
    $cfg['Servers'][$i]['extension'] = 'mysqli';
    $cfg['Servers'][$i]['auth_type'] = 'signon';
    $cfg['Servers'][$i]['user'] = '';
    $cfg['Servers'][$i]['password'] = '';
    $cfg['Servers'][$i]['SignonSession'] = 'SignonSession';
    $cfg['Servers'][$i]['SignonURL'] = 'http://myadminserver.net/phpMyAdmin-3.4.5-english/s.php';

    ?>

     
  • Marc Delisle
    Marc Delisle
    2011-12-03

    • assigned_to: nobody --> lem9
     
  • Marc Delisle
    Marc Delisle
    2011-12-05

    This bug was fixed in repository and will be part of a future release; thanks for reporting.

     
  • Marc Delisle
    Marc Delisle
    2011-12-05

    • milestone: 2093163 --> 3.4.8
    • priority: 5 --> 1
    • summary: No indication of success when running SQL if result is empty --> (ok 3.4.9)No feedback when result is empty, signon auth_type
    • status: open --> open-fixed
     
  • Marc Delisle
    Marc Delisle
    2011-12-21

    • status: open-fixed --> closed-fixed
     
  • Michal Čihař
    Michal Čihař
    2013-06-11

    • Status: closed-fixed --> fixed