Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#3403 left frame does not load on drop down change in chrome

3.4.1
out-of-date
nobody
5
2013-06-11
2011-08-12
Felix
No

phpMyAdmin version 3.4.1
Browser: Google Chrome: 13.0.782.112 m (have noticed on many older versions too)

When trying to select a database from the drop down list in the left frame nothing happens except a javascript error;

"Uncaught TypeError: Cannot read property 'document' of undefined" - which is shown to occur in common.js line 2 mainly and also sometimes 7 (I will get another instance of this each time i try and select another database).

I've noticed this has been a problem in google chrome for quite a while in various different versions of the browser and phpMyAdmin. I've never had problems with other browsers so I'm thinking it may be a bug in chrome, but it does seem odd that other drop down boxes do reload/change things without errors in other areas of phpMyAdmin.

Discussion

  • Marc Delisle
    Marc Delisle
    2011-12-07

    I cannot reproduce this problem, with phpMyAdmin 3.4.8. My Chrome is version 11.0.696.71 m running on Windows XP.

     
  • Marc Delisle
    Marc Delisle
    2011-12-07

    • status: open --> pending
     

  • Anonymous
    2012-03-26

    I had the same problem, left menu wouldn't refresh and got '"Uncaught TypeError: Cannot read property 'document' of undefined" error.

    Error for me was caused by an extension, by the process of elimination it seems to be 'Chrome Refresh' extension (https://chrome.google.com/webstore/detail/aifhnlnghddfdaccgbbpbhjfkmncekmn). I disabled this and everything works fine now.

    Chrome version is 17.0.963.83 m, on Win7x64 and phpMyAdmin 3.3.7deb7

     
  • Marc Delisle
    Marc Delisle
    2013-01-18

    • status: pending --> closed-out-of-date
     
  • Michal Čihař
    Michal Čihař
    2013-06-11

    • Status: closed-out-of-date --> out-of-date