#2157 (ok 2.9.0) table export/dump faulty

Latest_Git
fixed
1
2014-12-25
2006-05-30
Jürgen Wind
No

here some dumps from a tiny test database (irrelevant
data removed):

####################### pma280 CORRECT

-- phpMyAdmin SQL Dump
-- version 2.8.1
-- Server version: 5.0.21
-- PHP Version: 5.1.4
--
-- Table structure for table `te2`
--

CREATE TABLE `te2` (
`1` text NOT NULL,
`a` varchar(255) NOT NULL,
KEY `a` (`a`),
FULLTEXT KEY `1` (`1`)
) ENGINE=MyISAM DEFAULT CHARSET=latin1;

--
-- Dumping data for table `te2`
--

INSERT INTO `te2` (`1`, `a`) VALUES ('text1', 'aaaa'),
('test\nfirst', '');

####################### pma290 FAULT : field 1 instead
of `1` ( import fails ! )

-- phpMyAdmin SQL Dump
-- version 2.9.0-dev
-- Server version: 5.0.21
-- PHP Version: 5.1.4
--
-- Table structure for table 'te2'
--

CREATE TABLE te2 (
1 text NOT NULL,
a varchar(255) NOT NULL,
KEY a (a),
FULLTEXT KEY 1 (1)
) ENGINE=MyISAM DEFAULT CHARSET=latin1;

--
-- Dumping data for table 'te2'
--

INSERT INTO te2 (1, a) VALUES
('text1', 'aaaa'),
('test\nfirst', '');

######################## pma264 : CORRECT ( pma281 xml
not possible )

<?xml version="1.0" encoding="utf-8" ?>
<!--
-
- phpMyAdmin XML Dump
- version 2.6.4-pl4
- http://www.phpmyadmin.net
- Server version: 5.0.21
- PHP Version: 5.1.4
-->

<!--
- Database: `test`
-->
<test>
<!-- Table te2 -->
<te2>
<1>text1</1>
<a>aaaa</a>
</te2>
<te2>
<1>test
first</1>
<a></a>
</te2>
</test>

########## pma290 FAULT : structure&data missing

<?xml version="1.0" encoding="utf-8" ?>
<!--
-
- phpMyAdmin XML Dump
- version 2.9.0-dev
- Server version: 5.0.21
- PHP Version: 5.1.4
-->

<!--
- Database: 'test'
-->
<test>
</test>

########## pma290 export to file "CSV for MS Excel"
writes te2.xls (Stylesheet file !) :

"text1","aaaa"
"test
first",
##### ^- ending with comma !?

Discussion

  • Jürgen Wind
    Jürgen Wind
    2006-05-30

    • labels: --> Data Export
     
  • Michal Čihař
    Michal Čihař
    2006-05-30

    Logged In: YES
    user_id=192186

    The CSV for Excel export is IMHO correct (it ends with comma
    as the last value is empty), rest might be caused by recent
    conversion of export to separate plugins which handle
    parameters differently, I will check that.

     
  • Michal Čihař
    Michal Čihař
    2006-05-30

    • assigned_to: nobody --> nijel
     
  • Michal Čihař
    Michal Čihař
    2006-05-30

    Logged In: YES
    user_id=192186

    For SQL export you didn't enable backquoting, the checkbox
    still works, but defaul was wrongly changed, I fixed it.

     
  • Michal Čihař
    Michal Čihař
    2006-05-30

    • priority: 5 --> 1
    • summary: table export/dump faulty --> (ok 2.9.0) table export/dump faulty
    • status: open --> open-fixed
     
  • Michal Čihař
    Michal Čihař
    2006-05-30

    Logged In: YES
    user_id=192186

    XML export also fixed in CVS, thanks for reporting.

     
  • Jürgen Wind
    Jürgen Wind
    2006-05-30

    Logged In: YES
    user_id=1383652

    thx for your reply.
    enable backquoting, the checkbox default now OK
    i never noticed that checkbox before :)
    still some bugs left:

    ### csv ERROR: AUTO taken literaly
    "text1";"aaaa"AUTO"test
    first";"last field in last rec"AUTO

    ### word .doc ERROR: no doc format but html
    is that intended?

    ### xml.php v 2.12 2006/05/30 06:43 ERROR: XML Parsing
    Error: not well-formed
    Location: http://localhost/Html/tmp/te2.xml
    Line Number 20, Column 10:
    <1>text1-1(one line)</1>
    -^

    ### xsl.php v 2.4 2006/04/26 ERROR: XML Parsing Error: not
    well-formed
    Location: http://localhost/Html/tmp/te2.xsl
    Line Number 6, Column 3:
    <!DOCTYPE html PUBLIC....ansitional.dtd">
    --^

    (opened in seamonkey,IE,FF)

     
  • Michal Čihař
    Michal Čihař
    2006-05-30

    Logged In: YES
    user_id=192186

    word/xls are in fact HTML, but in a special way so that
    Microsoft Office programs can open it as Word or Excel
    documents. There was also wrong extensions for Excel export,
    I just fixed that.

    Numbers are probably not valid as starting char of xml
    element, I have no idea how to compatibly change it, so if
    you have columns called with numbers, you will probably have
    to live with it.

    AUTO is of course wrong, I'm fixing it.

    Thanks a lot for testing!

     
  • Marc Delisle
    Marc Delisle
    2006-09-20

    • status: open-fixed --> closed-fixed
     
  • Michal Čihař
    Michal Čihař
    2013-06-11

    • Status: closed-fixed --> fixed