#1 Java Script Error

closed
nobody
None
5
2002-09-10
2002-09-06
Nenad Djordjevic
No

I use IE6 and get error message:

Line: 280
Error: Invald Argument

This error exists only in 20.beta3 version of PHP
LayersMenu.

In line 280 of file layersmenu.js I find at end of line:
`+ "px"`

In version 2.0beta2 (in which I do not get error message)
you do not have `+ "px"` at end of line.

Discussion

  • Marco Pratesi
    Marco Pratesi
    2002-09-10

    • status: open --> closed
     
  • Marco Pratesi
    Marco Pratesi
    2002-09-10

    Logged In: YES
    user_id=65709

    Evidently this is due to one of the many bugs of IE;
    it is *not* a bug of phplayersmenu, as the correct version
    of the code is just the one in 2.0beta3.

    Nothing strange, as Microsoft has widely proven to be not able
    to develop a good browser, and, in fact, phplayersmenu
    has already a considerable quantity of code devoted
    to workaround IE bugs.

    BTW, Opera 5 has the same problem, hence I have already
    prepared a patch to consider Opera 5 as a distinct case.
    For the final 2.0.0 release, I will repeat all tests, also
    on IE,
    and I will consider distinct cases for the IE versions affected
    by this bug.