Media link prob post upgrade

Help
becky
2013-01-07
2013-05-30
  • becky
    becky
    2013-01-07

    Hi
    I upgraded from 4.2.4 to 4.3 today.  Everything appears to be fine except some media links aren't working.  I've confirmed that the files are on the server in the expected location but the images are not displayed.  When I click on the image I get "Clearbox error: Could not open image".

    Could it be related to when I imported the gedcom - I chose Yes for the database and No for Media.

    An example is:
    http://www.nryonline.co.uk/phpgedview/mediaviewer.php?mid=M108

    Thanks in advance.
    Becky

     
  • Gerry Kroll
    Gerry Kroll
    2013-01-07

    Did you follow the instructions in the Help post exactly?

    You probably have a Permissions or Ownership problem on some of the files in the media directory.

    When upgrading from a working 4.2.4 installation to 4.3.0, all you need to do is to is to replace the PGV 4.2.4 program files, keeping just the data file "config.php" and the data directories "index" and "media".  You don't even have to mess with the database.

     
  • becky
    becky
    2013-01-07

    Thanks for your reply.

    I followed the steps as outlined below which describe re-importing the gedcom to database:

    The update procedure consists of:
    (a) Make a full backup of the database and the existing site files, so that you can revert if necessary.

    (b) Using the old program, export the database to a GEDCOM.  There's no need to download this file.

    (C) Delete everything in the server directory where PhpGedView is installed.  BUT: do not delete anything that you wish or need to preserve.  You MUST keep file "config.php" and directories "media" and "index".  If you've created additional language files, identified by "extra.xx.php" in the "languages" directory, you need to keep these too.  Likewise for any module configuration files or for additional themes.

    (d) After having used your favourite Unzip program, such as 7-Zip, you'll end up with a directory containing all of the PhpGedView program.  Delete subdirectories "media" and "index" so that you won't overwrite the ones already on the server.  There is no file "config.php" - it's called "config.dist", and you can delete this.  Delete also any modules you don't want to use by deleting their subdirectories in the "modules" directory.  Likewise for themes you don't wish to use and for languages you don't want your users to access.  You MUST keep the English language files even if your site will never allow the use of English.

    (e) Use your favourite FTP client to copy the remaining PhpGedView files and directories to the server directory where PhpGedView is installed.

    (f) Use your favourite FTP client to set the permissions of PhpGedView files and directories.  644 is OK for most servers, but some, mine included, want 755.  You need to set the permissions on the "index" and "media" directories, and all their contents, to 777.  If your site needs some configuring, set the permission on "config.php" to 777, but remember to restore that permission to 644 (or 755) when you're done.  Note: the 755 permission is never wrong, even when the server will accept 644.  "4" means "read" while "5" means "read or execute".

    (g) Launch PhpGedView, log in with Site Admin rights, and access the Manage GEDCOMs page.  Re-import the GEDCOM that you exported in step (b).  Be sure to let PhpGedView delete existing database information.  Tell it also to delete existing media links.  The media option is in there to handle situations where the incoming GEDCOM is missing valuable media information.  This happens when the GEDCOM is created by older versions of Family Tree Maker, among others.

     
  • becky
    becky
    2013-01-07

    Hi
    Thanks again, your question made me go play with the file permissions.  I set them to 644 which stopped the site working so I tried 755 and it seems to be working again,  I need to check more media files but looking good so far!

    Thanks.

     
  • Gerry Kroll
    Gerry Kroll
    2013-01-07

    Yup, my servers, both running Ubuntu, demand 755.

    One server is a true connected-to-the-Internet box. The other is running on my Windows 7 laptop with the help of Oracle VM VirtualBox and isn't visible on the Internet.  This is the one I do all my testing and development on.

     
  • Gerry Kroll
    Gerry Kroll
    2013-01-07

    I forgot to add:
    The instructions you followed are correct.  They were written for the general case, upgrading from any version of  PGV to 4.3.0.  Upgrading from 4.2.4 to 4.3.0 is a special case, where no database changes were made.