Fatal Error importing GEDCOM

Help
Baruch
2011-09-12
2013-05-30
  • Baruch
    Baruch
    2011-09-12

    I am using PGV 4.2.0 and my URL is : www.krotman.co.il/pgv
    while trying to import a new updated GEDCOM I recieved : Fatal error: Allowed memory size of 132120576 bytes exhausted (tried to allocate 1449086 bytes) in /home3/krotmanc/public_html/pgv/uploadgedcom.php on line 951

    I've talked with the host support and been adviced ot change the PHP.INI to MEMORY_LIMIT : 128M then to 140M and evento 256M. Also changed the phpconfig to SINGLE PHP.INI

    I am still getting the same error

    any idea ?
    thanks, Baruch

     
  • Stephen Arnold
    Stephen Arnold
    2011-09-12

    For PGV to use the newly allocated memory, you have to change it's configuration as well. You can see this in the PHP INFO from the Admin page.  LOCAL <=> MASTER.   Review these to see if the new 256mb is reflected in the Master column, and that you have taken advantage of it locally within PGV.
    -Stephen

     
  • Gerry Kroll
    Gerry Kroll
    2011-09-12

    The mempry PhpGedView is allowed to use is subject to two limits, and the lower of the two is what applies.

    The first limit (the one you talked to your host support about) is set in PHP.INI.  It applies to all PHP programs, and not just ot PhpGedView.  The second limit is set in the PhpGedView site configuration.  To configure this value, you need to launch PhpGedView, log in as Admin, access the Admin menu page, and select the "Configure" option.  The memory limit is one of the values you can change.  Make sure that "configure.php" is writable before trying to set this configuration.

    Note:
    You should consider upgrading PhpGedView to a more recent version.  I recommend you go to 4.3.0.  Download and upgrade instructions are in a recent Help topic that begins with "Repost:".

     
  • Baruch
    Baruch
    2011-09-12

    Thanks for your reply.
    I can't see it from the ADMIN page,(it moves me back to the manage GEDCOM page)  but I see the PHP.PHP directly, and it's same : MASTER  and LOCAL

     
  • Baruch
    Baruch
    2011-09-12

    yessss..  now it works ! Thank you very much canajun.

    The latest version that I can find is 4.2.4.   can't see 4.3

     
  • Stephen Arnold
    Stephen Arnold
    2011-09-12

    Baruch
    I'm not sure HOW you can see the "Local" (PGV assigned) memory from the method you've described. I'm not familiar with any method that could be used to do so other than examining the config.php text file in the root PGV directory and reading the line:
    $PGV_MEMORY_LIMIT='xxxM';

    You could change this manually, but risk adding a BOM to the file if you use the wrong text editor.

    -Stephen

     
  • Stephen Arnold
    Stephen Arnold
    2011-09-12

    As Gerry stated:
    I recommend you go to 4.3.0. Download and upgrade instructions are in a recent Help topic that begins with "Repost:".

     
  • Baruch
    Baruch
    2011-09-12

    Thanks again to both of you.
    I will upgrade soon