Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

Users accounts not working after upgrade

Help
Kipp
2011-04-23
2013-05-30
  • Kipp
    Kipp
    2011-04-23

    I just recently upgraded from v4.2.3 to v4.2.4 and my account as admin is functioning but all my other users are incomplete.  After looking in the DB table, they appear to be there but when looking at the user list via the web page, there accounts are listed but only there usernames.  There full names are missing, the date registered is 31 December 1969 - 6:00:00pm for all of them.  There last login shows 31 December 1969 - 6:00:00pm ‎(41 years, 4 months, 2 days ago‎) and the user verified and admin approved are all no.  It appears the website is not reading the table correctly.

    I have no idea what to do so I really would appreciate some assistance.

     
  • Gerry Kroll
    Gerry Kroll
    2011-04-23

    There were no database table changes between 4.2.3 and 4.2.4.  It sounds as if your users table is damaged.

    You should restore all of the database tables from the backup you should have made before you upgraded.  You should also restore the "config.php" file from your 4.2.3 installation into your 4.2.4 set-up.

    If you remembered to export your 4.2.3 database to a GEDCOM before you started the upgrade, or if you're sure you have an up-to-date copy of that GEDCOM, you should log in as Administrator, access the Manage GEDCOMs page, and upload and import a replacement GEDCOM using the up-to-date GEDCOM.