Escaping apostrophes and quotes after php 5.3

Help
2012-01-18
2013-05-30
  • I'm running GedView 4.2.3 and recently my host upgraded to php 5.3.3. Previously, when entering text that contains quote marks or apostrophes everything was fine, but now, after the upgrade, any text that I enter that contains quote marks or apostrophes gets entered in the db with the backslash escape characters.  E.g. \'this is a test\'  Thoughts? 

     
  • Gerry Kroll
    Gerry Kroll
    2012-01-19

    Did you not read the post just below this one (the one about apostrophes in names)?  Your answer is right there!

     
  • Yes, I did.

    However, I was also not clear whether GedView 4.3.0 is a stable release. The current release is identified as 4.2.4 and I certainly do not wish to introduce unstable code.

    It also appeared that the other user's problem was related to an update in the gedview version whereas my issue appears to have begun with an upgrade to php. 

    Thanks for your advice!

     
  • It is likely that before the PHP upgrade the option magic_quotes_gpc was off, and since the upgrade it is on. If your hosting provider allows you to use .htaccess files you might be able to disable magic_quotes_gpc yourself by adding the following:
    # Disable magic_quotes_gpc
    php_flag magic_quotes_gpc off

    I just verified that it works for my 4.2.4 installation.

     
  • Gerry Kroll
    Gerry Kroll
    2012-04-07

    mjockers:
    You clearly didn't do enough research on the issue of "is the SVN (aka 4.3.0) version stable".

    It has been stated (NOT "claimed") numerous times that the SVN version contains a lot fewer bugs that the so-called "stable" 4.2.4, and that there no bugs in 4.3.0 that aren't also in 4.2.4.

    Take your cue from this.