Cannot login anymore

Help
cemond
2011-12-04
2013-05-30
  • cemond
    cemond
    2011-12-04

    First let me tell you that my installation was working perfectly, than I took a break over the summer, now I'm going back into it and I'm running into problems.

    First I have these 2 lines showing at the top of the page

    ERROR 2: Cannot modify header information - headers already sent by (output started at /home/newgemo9/public_html/PhpGedView/themes/standard/theme.php:385)

    Warning: Cannot modify header information - headers already sent by (output started at /home/newgemo9/public_html/PhpGedView/themes/standard/theme.php:385) in /home/newgemo9/public_html/PhpGedView/includes/functions_print.php on line 523

    And when I'm trying to login I get the message that the user cannot be authenticated, I had the password saved on my computer so I know it is the right password.

    I cannot login as the administrator either.

    Anybody knows what I should do?

     
  • Stephen Arnold
    Stephen Arnold
    2011-12-04

    First, it seems you or someone else has either replaced or opened and saved the theme.php file with a BOM. You can not have BOM (byte markers) in your text (php) files. Download a replacement from SVN and change (replace) the file on your server. You do not advise which version you are using, but you should be using the most recent code - v4.3 SVN. Older versions of the code have security breaches.

    Secondly, did you look at your SQL tables?  Do your users still exist? Have you tried to have the system send you a new password? If so, and you have replaced ALL your files or at least your theme.php file (change themes might help), then you may have to manually change the password hash in the database to PASSWORD or CHANGEME. These password hashes are noted on other threads about this subject on these forums.
    -Stephen

     
  • cemond
    cemond
    2011-12-04

    1) I think I'm using 4.2.4 but not 100% sure
    2) Yes my users are still in the database
    3) When I tried to get a new password I'm getting this message "Could not verify the information you entered. Please try again or contact the site administrator for more information."

    Thanks for the help, I will change the files and see if that fix the problem.

     
  • Gerry Kroll
    Gerry Kroll
    2011-12-04

    You get the "could not verify …" message when the userid you entered does not exist in the database.

    Follow the advice I gave in my 25 November 2011 post in the recent Help topic "I lost my users".

    Look at the file "changelog.txt".  That should tell you what PGV version you're running.