Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

How to add image to the pink box

Help
Irene Eng
2011-10-01
2013-05-30
  • Stephen Arnold
    Stephen Arnold
    2011-10-01

    From the media or album tab, select ADD A NEW IMAGE. Following the GUI and approve the addition.
    Select Feature/Highlight media object = YES to have it be the PRIME image.
    To be the primary image for profile display, it should be a level one image and selected a prime or none (default), but prime is preferred.
    -Stephen

     
  • Gerry Kroll
    Gerry Kroll
    2011-11-12

    Irene:
    Are you talking about the pink or blue boxes in charts?  If so, there's an option that determines whether all highlighted images should be shown on charts or not.

    You will find this option in the GEDCOM configuration, Multimedia section, General group.  The option is labelled:
    "Show highlight images in people boxes"

     
  • I am also trying to show pictures at individual records instead of the generic silhouettes, but I can't find "GEDCOM configuration, Multimedia section, General group. The option is labelled: "Show highlight images in people boxes"


    can anybody tell me where to find this parameter.

    Thanks

    Pim

     
  • Stephen Arnold
    Stephen Arnold
    2011-11-17

    Pim
    Your question is not clear to me.
    DId you read my earlier post? Do you have multimedia enabled?

    From the media or album tab, select ADD A NEW IMAGE. Following the GUI and approve the addition. Select Feature/Highlight media object = YES to have it be the PRIME image. To be the primary image for profile display, it should be a level one image and selected a prime or none (default), but prime is preferred.

    The section to which Gerry referred, and now you, is to add the INDI highlighted thumbnail to the charts in the "person boxes", not on the INDI page you've shown.
    Your configuration for this would be:
    Manage GEDCOMs > Edit Configuration file > Multimedia section > General subsection
    Set "Use Thumbnail" to YES, Set "Use Silhouettes" to YES, Set "highlight images in people boxes" to YES
    SAVE your changed configuration. Add the image you wish to use for the profile and be sure to select "highlight" = YES
    -Stephen

     
  • Stephen,

    your first post in this topic was perfectly clear to me, and I executed it as described, but it didn't seem to do anything.

    I just logged on to follow your instructions once again, but I found that now the picture was there…..apparently it takes awhile for the changes to take effect.

    Thanks for the help!

    Pim

     
  • KenN
    KenN
    2011-11-17

    Probably browser cache had not been cleared!

     
  • Gerry Kroll
    Gerry Kroll
    2011-11-17

    One thing that should be made absolutely clear is that media support in PhpGedView is done in two parts:

    The first is to make sure that pictures, etc. are actually in the server's file system.  You can use PGV to upload media files and to generate thumbnails as part of the upload process.  There are alternatives to using PGV for this (such as FTP), but these alternatives don't create the thumbnails automatically.

    The second is to add media objects to the database and to link these objects to people, families, and sources in the database.  This process is done when you edit a media file.  You're not actually editing the file, you're editing information about the file.  The best place to do this is the Manage Media page, although there are other, more clumsy, ways of doing it. 

    Provided you have the GEDFact_assistant module installed, you can very easily manage all links of the media object to several people, families, and sources in your database.  Notice that you're dealing with a media object (an entity in the database) and not with the media file that the media object points to.

     
  • Sorry this newb is lost once again….After the picture showed up yesterday I had to delete it again, because I needed to change the picture.

    Followed the same procedure again, and I think I did it all correctly:


    But once again it refuses to show up……cleared browser cache, used different browsers, but nothing seems to  help. I must be missing something basic.

    Just to clarify, I am totally brand spanking new to genealogy, phpgedview etc. so please have patience with me.

    Pim

     
  • I feel really stupid. Eventhough I accepted the changes everytime I edited a record, I just found a whole bunch of changes that had to be accepted once again at the welcome page.

    Apparently I have to study the workings of this software more before entering records…….

     
  • Stephen Arnold
    Stephen Arnold
    2011-11-18

    Pim
    First, Set your personal user profile to AUTO-ACCEPT, unless you don't trust the changes you make. Then "accepting" changes will not be an issue for your work.

    Second, Was this not a photo of the right person?

    I had to delete it again, because I needed to change the picture.

    There was no need to delete media item link unless it was linked to the wrong persons. If you didn't wish it to be the featured "highlighted" item, then modify the configuration of that media object by editing the "highlight" status, changing it to NO. Then it will appear as a media item on the person's tab, but not in their profile image.

    Yes, it sounds like you've got a good deal of familiarization to do. We are here to help with serious, complicated issues, but you must take the time to learn the basics on your own.
    -Stephen

     
  • OK, thanks for the tips, I set my profile to auto-accept, so that issue is history.

    Second, Was this not a photo of the right person?

    No, as a test I uloaded the first picture i found on my desktop…..than I had to change it.

    I seem to be getting the hang of it. Thanks for all the work you guys put in this great piece of sofware. I'll try not to waste your time.

    Have a great weekend

    Pim

     
  • Gerry Kroll
    Gerry Kroll
    2011-11-18

    Pim:
    You're not wasting our time.   We're here to help.

    Sometimes, what is obvious to people who have been using the software for a long time is quite incomprehensible to folks who are new to it.  You should try to find the answers yourself by studying the comprehensive Help system.  However, if you just can't find the solution to your question in a reasonable time, just ask for help.

    When you're asking for help, be sure to NOT hijack someone else's topic.  It's best to start your own.