Media Permission problems

Help
Ben Green
2012-02-07
2013-05-30
  • Ben Green
    Ben Green
    2012-02-07

    Hi, it's my first post here, so hello to everyone.

    I'm sure this topic has been discussed over and over, but I have been searching and not found anything that I've not tried (famous last words !).

    I have a fair bit of experience in installing and managing websites and image galleries, and understand UNIX file permission.

    Yet I just can't get a new install of v4.2.4 to display images or thumbnails. I've uploaded 3 jpeg image files and can see them if I view the user record individually. Yet they won't display within the 'family tree' structures.

    I've set the following to 777 permission:
    media, media/MediaInfo.txt, media/thumbs/index.php,media/thumbs/ThumbsInfo.txt, and media/thumbs .But if I click on 'Manage MultiMedia' it tells me to correct read/write permissions.

    Correct read/write/execute permissions

    Permissions Not Set 
    Permissions Set 
    Permissions Not Set 
    Permissions Set 
    Permissions Set 
    Permissions Not Set 
    Permissions Set 
    Permissions Not Set 
    Permissions Set 
    Permissions Set 
    Permissions Not Set  

    I'm a bit lost - any ideas

     
  • Gerry Kroll
    Gerry Kroll
    2012-02-07

    You should be using the "SVN" version of PhpGedView in preference to the "stable" 4.2.4 that you're running.  The download and install instructions are in a recent Help topic whose title begins with "Repost: …".  Don't let the fact that it's the SVN version fool you:  This version is just as stable as 4.2.4, but it contains a lot of bug fixes.

    The "SVN" version won't change the behaviour of media files.

    Firstly, the "Correct permissions" link is just a link - it's not a demand that you change anything.

    If you're seeing the media when you call up an individual record and you can also see them when you're on the Manage Media page then you've done things correctly. 

    There's an option in the GEDCOM configuration, "Multimedia" section that determines whether media are to be shown in charts.  The option is labelled "Show highlight images in people boxes" and is in the "General" group of options.

     
  • Ben Green
    Ben Green
    2012-02-08

    Thanks for the reply canajun2eh,
    OK, I think I was just making a 'newbie' error. The 'Correct Permissions' section really made me think I *needed* to do something.
    Anyhow, I've installed a new site using the 'SVN' version, and it's running well (on a Synology DiskStation !)
    The problem I still have (which is what made me suspicious in the first place) is that image thumbnails are not showing  the charts, despite me having all the Media options selected within the GEDCOM config. The only option I've set to 'No' is 'display silhouettes' as I wondered if this was overlapping the image, but it made no difference. Please can you clarify, should I see the image thumbnails in the chart ? I can confirm that I'm able to view the images by pointing my browser directly to image files within the /media and /media/thumbs/ directories and they can be seen in the Manage Media section.

     
  • Stephen Arnold
    Stephen Arnold
    2012-02-08

    Do the thumbnails exist? how large are your image files? anything over 100-150k in the main jpg image is really wasted bandwidth and a burden to the system. How much memory have you assigned to PGV? Can we see this ourselves (public site? URL?)? There are so many factors that can affect display, we may need admin access to review these since we (and you) know PGV's code works, if properly configured.
    -Stephen

     
  • Gerry Kroll
    Gerry Kroll
    2012-02-08

    As Stephen has suggested, it might be best if one of us were temporarily given Admin rights to your PhpGedView site, so that we can look at this directly.  I'm sure it's a simple configuration problem.

    Please create a temporary userid with Admin rights, and e-mail the details, including the site URL, to me:  gkroll at keldine dot ca

     
  • Ben Green
    Ben Green
    2012-02-08

    Hi canajun2eh,
    Thanks for the offer or help - I've emailed you the details.
    - Stephen, my images are much smaller that 100kb. Not too sure about the thumbnails (unless those are the images I initially see when clicking on Manage Media), although I did get confirmation they'd be produced.

     
  • Gerry Kroll
    Gerry Kroll
    2012-02-08

    This was a simple problem that would have been VERY difficut to diagnose without the login credentials.

    The media objects had not been accepted into the database - they were waiting for Admin approval.  When I accepted them, media worked properly.

    I suggested to the user that he should set the privileges of his own account to auto-accept changes..  This would simplify things greatly

     
  • Ben Green
    Ben Green
    2012-02-09

    Thanks canajun2eh,
    Whatever you did has fixed this. I really appreciate you spending the time to help me on this.
    However, I can't see any setting for 'auto-accepting' changes. Please can you tell me where this is.
    It seems a bit odd as my user account is the administrator account, so why would it need to approve itself ?

     
  • Ben Green
    Ben Green
    2012-02-09

    I asked too soon….just been looking again and this option is found from clicking on the username from the User List and ticking the "Automatically accept changes made by this user" box.
    I still can't see, when viewing Manage Multimedia, how you determine if an image is waiting to be 'accepted into the database'.

     
  • Stephen Arnold
    Stephen Arnold
    2012-02-09

    As Gerry indicated, the system can not see and isn't prepared to handle files that have not yet been accepted into the database. All data entered is held in a preliminary staging sequence until reviewed and accepted by a site administrator. You can't expect to be able to view anything properly until it is actually passed into the DB.

    Also, to allow any user (including yourself as an admin) to Auto-Accept entries, you must tick the checkbox for every user you would grant this right, in their individual user profile.  I have over 400 user contributors with about 15 who add a lot and know the rules - I still don't allow their entries to be auto-approved as I find I need to tweak their entries regardless of how good they think they are. Per my conventions, they use unacceptable punctuation, leave out important parts of the PLAC descriptor, type complete month dates instead of MMM, use wrong qualifiers for estimated dates (BEFORE instead of BEF or c. instead of ABT…) and I must review every entry.
    PORTAL > USER ADMIN > USER LIST > select your profile > half-way down, right after RIGHTS/ROLES, Automatically accept changes made by this user and tick the checkbox.
    -Stephen

     
  • Stephen Arnold
    Stephen Arnold
    2012-02-09

    Like any change or addition, use the link to REVIEW CHANGES on every page (in a different place depending upon theme). Also, you can add the block to your portal page or your welcome/home/main index page.
    -Stephen

     
  • Gerry Kroll
    Gerry Kroll
    2012-02-09

    Hello, Semnoz:
    You asked, "How do you tell that something is waiting to be approved?"

    On the Manage Media page, the media items had solid blue borders around them. 

    That means the item is new and is waiting for approval before it can be added to the database.  The same blue border could occur around various facts on an individual's Personal Details page, and would mean the same thing.  If there's a red border, the item is waiting to be deleted.  Usually, there would also be an accompanying blue border to indicate delete/add  (i.e., "replace").

    After you have logged in, the main Welcome page might have a block on it that shows that changes are waiting for approval.  You could tailor your personal Portal page to show the Pending Changes block.  That way, after logging in, you'll see the pending changes immediately.  If there are no pending changes, the block won't appear.