Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

problem with diaeresis (or two dots)

Help
Han
2012-08-20
2013-05-30
  • Han
    Han
    2012-08-20

    Why are the letters with diaeresis sometimes wrong and sometime good. For example: I have in the place hierarchy the folowing names.

    Indonesi�
    Indonesië

     
  • Lester Caine
    Lester Caine
    2012-08-20

    It's a lot dependant on what fonts are loaded for use with your browser or other software. The ? symbol normally indicates that there is not a character available in that font. Not a lot we can do if the browser can display the full unicode character set.

     
  • Stephen Arnold
    Stephen Arnold
    2012-08-20

    You are demonstrating a UTF-8 problem, either within the font and browser you are using, or naturally within the data from the database. If the core data has not been corrupted, then you may wish to use Greg's tool for converting your database from Latin to UTF-8. Check your DB to see what collation you are currently using.
    -Stephen

     
  • Gerry Kroll
    Gerry Kroll
    2012-08-20

    The problem is probably caused by incorrectly coded letters originally created by the Aldfaer program and then imported into PhpGedView.  These would be displayed incorrectly.  Other data, that you have entered after the original import from Aldfaer, would be displayed properly because it's in the database in the UTF-8 character set.

    I can fix these errors for you.  You would need to export the existing database to a GEDCOM and then e-mail this GEDCOM to me.  It's important that, if you want my help, you do NOT make any database changes after you have exported the database to a GEDCOM.  You can continue making changes after you have re-imported the corrected GEDCOM that you will receive from me.

     
  • Han
    Han
    2012-08-21

    I think that I understand what the problem is. When I change the GEDCOM-file with PHPGEDVIEW then everything is fine. But when I change it with GEDPlace.exe there is a problem. In the database is the general setting UTF8_general_ci and in the PHPGETVIEW database I see UTF8_bin as Collation.

     
  • Gerry Kroll
    Gerry Kroll
    2012-08-21

    GEDPlace.exe works only on a GEDCOM that is in the ANSI/ASCII character set.  It is NOT able to work in the UTF-8 character set that is used by PhpGedView.

    Here's what you need to do to get things working properly:

    1. Log into PhpGedView using your Admin userid and then access the Manage GEDCOMs and edit Privacy page.

    2. On the line where your GEDCOM file is listed, click the Download link.  This will open the Download GEDCOM page.

    3. Clear the Zip File(s) checkbox and put a checkmark into the Convert from UTF-8 to ANSI (ISO-8859-1) checkbox.  Do NOT change any of the other default options.

    4. Click on the Download Now button to download the GEDCOM.

    5. Use GEDPlace.exe to correct the various Place entries in the downloaded GEDCOM.

    6. Log into PhpGedView using your Admin userid and then access the Manage GEDCOMs and edit Privacy page.

    7. On the line where the GEDCOM title is shown, click the Upload Replacement link and then browse to the location on your local PC where the GEDCOM that was worked on by the GEDPlace.exe program is located. 

    NOTE:  If the GEDCOM file size exceeds the upload limit set by your server, you will have to use a program like 7-zip to convert the GEDCOM text file to a ZIP file and then upload that instead of the original GEDCOM file.  The upload limit is often set at 2 Mb.

    8. After the file has been uploaded (and possibly converted from a ZIP format to the usual text format by PhpGedView), PGV will begin importing.  Let the program convert the file to UTF-8, and also let it replace the database contents.  If you are asked about media links, let the program delete existing media links.

    If you do not wish to upload a ZIP file and prefer to work strictly with the uncompressed GEDCOM file, you will need to use an FTP program to upload your GEDCOM when it is bigger than the server's upload limit. In this case, upload the GEDCOM to the "index" directory within the PhpGedView installation on the server.  Make SURE the file name is identical to what you used previously.  Also make SURE that the permissions on the uploaded file are set to 777. 

    After having used FTP to upload a replacement GEDCOM, you will need to log into PhpGedView with your Admin userid and then, on the Manage GEDCOMs and edit Privacy page, you need to click the Import link and then proceed as above.  Be SURE to let PGV convert the file to UTF-8 and also replace the database contents.

     
  • Han
    Han
    2012-08-21

    I came to step 7 but I had to push the continue-button 3-times. After that I have to import it again. After I have started the import proces 3 times I can't continue. I come back to Current GEDCOMs and The GEDCOM has not yet been imported.
    I work local, is there no other way to import ( replace it in localhost) the GEDCOM en convert it to UTF-8?

     
  • Stephen Arnold
    Stephen Arnold
    2012-08-22

    Why would you have to press continue at all? It is easily set to automatic.
    Which version are you attempting to import into? Hopefully not v4.2
    What parameter did you set for import time? If your script processing time is set to 30 seconds, then set your import time to 20 seconds. If that proves too long, try 15 seconds. If that is too long, try 10 seconds.

    Sounds like you have an underpowered processor, too little memory,  or possibly a misconfigured (or poorly optimized) MySQL config.

    I imported my 68mb GEDCOM into my local machine in 9 minutes the other day with webtrees, which is significantly better optimized for import than PGV. PGV took an hour and a half on the same machine and the same family tree.
    -Stephen

     
  • Han
    Han
    2012-08-22

    My GEDCOM is only 1.13 Mb. Its not working properly. When I set the timelimit to 30 seconds or more thetimelimit starts only 3 times. There is no difference between automatic start again or start again by hand. When I set the limit to 20 seconds I get the following message after 5 times restart:
    Fatal error: Maximum execution time of 20 seconds exceeded in C:\xampp\htdocs\phpgedview\includes\functions\functions_UTF8.php on line 49

     
  • Han
    Han
    2012-08-22

    I tried it more then 10 times and as much fatal errors and at last I succeeded.

     
  • Gerry Kroll
    Gerry Kroll
    2012-08-22

    Han:
    Somewhere in your configurations you have a 20-second time limit.  I'm not talking about the Import time limit.

    One time limit is in the PHP configuration - the php.ini file.  The other is in the PhpGedView system configuration.  When PhpGedView is running, the lower of the two time limits is used.

    During Import, you have to set another time limit.  This one should be a little less than the time limit PGV uses as discussed in the previous paragraph.  The reason for this is discussed in the Help text associated with this input field.

    If you set the Import time limit too big, you will get the "Time limit exceeded" error.

    Having to press the Continue button, either automatically or manually, is normal.  When I imported your GEDCOM into my system, the Import took about 75 seconds with one automatic Continue.  My Import time limit is set to 60 seconds, and the system time limit is at 300 seconds.

    My own GEDCOM takes about the same length of time.  I have over 5,000 people but a LOT less Notes text.

     
  • Han
    Han
    2012-08-22

    In the php.ini is the time limit everywere 60 s and a maximum of 128 Mb. A few days ago I could set the time limit in PHPGEDVIEW at 60 seconds and it worked well. It took about 150 seconds. Yesterday and today I lowered it down to 5 seconds and it didn't work. Sometimes I got the fatal error but other times the program jumps back to the 'Current GEDCOMs
    ' page. I logged out a few times and at last I did it with 40 seconds timelimit.

     
  • Gerry Kroll
    Gerry Kroll
    2012-08-22

    Han:
    The 60 second time limit in php.ini should be OK.

    You need to see what the PhpGedView configuration is set to.  Find this in the GEDCOM configuration.  This should be 60 seconds also.

    The time limit set for the Import function should be about 55 seconds.  If this is set too close to the 60 second limit you have everywhere else, PGV will not be able to pause the Import before the time limit of 60 seconds runs out. 

     
  • Han
    Han
    2012-08-22

    I can't find the GEDCOM configuration. I've looked in config.php and in the admin page.

     
  • Gerry Kroll
    Gerry Kroll
    2012-08-22

    Han:
    Surely you should know this by now!  GEDCOM configuration:

    1. Log in as admin and access the Manage GEDCOMs and edit Privacy page.
    2. On the Configuration file line, click on the Edit link.

     
  • Han
    Han
    2012-08-22

    For me its like windows; click on start when you want to stop :-)
    I found it and it's 60 seconds but will I remember were to find it later? Its a program wit many possebilleties and you can enter a lot of issues from many ways. Mabey its easy when you develloped and work with it all day but for me its hard learning.

     
  • Gerry Kroll
    Gerry Kroll
    2012-08-23

    Han:
    All you need to remember is that there are only four sets of configurations, excluding any that are part of various modules.

    All of the configurations are accessible through the Admin page, which you get to by clicking the "Admin" link at the top of any page after having logged in as Administrator.  This action launches an Admin menu page, and then you navigate deeper into the program by clicking various menu options.

    The "Configuration" menu option launches the Configuration dialogue.  It controls the over-all behaviour of the site, including how PhpGedView connects to the database.   You need to remember that you have to click the "Next" button when you make any changes, otherwise there is a possibility that your changes won't be saved properly.  One of these days I'll get around to fixing this.

    The "Configure supported languages" option can be accessed through the Configuration dialogue mentioned above, or it can be accessed directly from the main Admin menu.  Here you control which languages your site will make available to your users.  When you edit an individual language, you can change the behaviour of your site when that language is selected by a user.  For instance, you can change the country flag icon (I use the Canada flag to represent English).  You can also control the appearance of dates or whether the family name should always be shown first (as it is in Hungarian).

    The "Manage GEDCOMs and edit Privacy" option launches a subordinate menu where you can add another GEDCOM or replace the existing database contents with new information from a replacement GEDCOM.  You can also change various aspects of program behaviour related to the currently active GEDCOM.  This is the "GEDCOM configuration" we originally talked about.  Other things you edit here are the various Privacy settings that come into play when a user selects that particular family tree (you can have several family trees on the same site).

    The other important option you can access through the Admin menu is "User administration".  Here you control the various rights of individual users.  You can also change the login userid of individual users, or change their login password.  Once they are logged in, individual users can change SOME of their profile, including their own login ID and their own password.  However, as the Admin, you have much more control over what your users can do.

     
  • Han
    Han
    2012-08-23

    Thank you!