Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

Upgrade Failure 4.21 ->4.24

2011-09-08
2013-05-30
  • glen stadig
    glen stadig
    2011-09-08

    I attempted an upgrade from 4.21 to current 4.24
    After i copied up the new files ommiting the index / media and config.php as instructed my site wont open.
    ancestors.stadig.org
    Not sure what the best approach is to recover at this point
    I checked the databases and the SQL looks ok no errors
    I get this error message  - - "The webpage at http://ancestors.stadig.org// has resulted in too many redirects. Clearing your cookies for this site or allowing third-party cookies may fix the problem. If not, it is possibly a server configuration issue and not a problem with your computer.-"
    I tried removing cache etc no luck

    Any ideas? Any docs?
    Do i start from scratch and try to import all my data and media?
    I tried changing the config.php to the new one just to see if it could load, that didn't work so i changed it back to my orginal one.

    Any help greatly appreciated

     
  • glen stadig
    glen stadig
    2011-09-08

    FYI - I try accessing in Firefox and get a similar error
    "Firefox has detected that the server is redirecting the request for this address in a way that will never complete."

     
  • Gerry Kroll
    Gerry Kroll
    2011-09-09

    Download and manually edit file "config.php", and then send it back to the server.  Make sure you edit and save this file as a plain ASCII text file. 

    Remove the values defined for variables $SERVER_URL  and $LOGIN_URL  (These fields should be empty.)

    Make sure the value defined for variable $AUTHENTICATION_MODULE is authentication.php

    If this doesn't work, you can replace the "config.php" file on the server with the one that came with the 4.2.4 package.  Just be absolutely sure to enter exactly the same database connect values and index directory location that you have in the "config.php" file you downloaded from your server before you tried the local edit.

    Note:
    You should really be running the latest-and-greatest 4.3.0 .  Instructions are in the recent Help post whose title begins with "Repost:"

     
  • Gerry Kroll
    Gerry Kroll
    2011-09-09

    Further note:
    This topic properly belongs in the Help forum, since you're asking for help.