Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

5.3 PDO errors - update today

eydaimon
2009-11-08
2013-05-30
  • eydaimon
    eydaimon
    2009-11-08

    I just ran a svn up to make sure I had the latest fixes for 5.3. I'm seeing the error below. Any idea what's wrong with my installation ?

    ERROR 2: PDO::__construct() :  Invalid argument (trying to connect via unix://)
    0 Error occurred on in function __construct
    1 called from line 115 of file class_pgv_db.php in function createInstance
    2 called from line 267 of file session.php in function require_once
    3 called from line 79 of file config.php in function require_once
    4 called from line 41 of file install.php

    Warning: PDO::__construct() :  Invalid argument (trying to connect via unix://) in ROOT/includes/classes/class_pgv_db.php on line 115

     
  • Greg Roach
    Greg Roach
    2009-11-08

    It would be helpful to know exactly which version you are upgrading from/to.

    What database are you using (sqlite, mysql, etc.)?
    What connection parameters do you have for your DB?

     
  • eydaimon
    eydaimon
    2009-11-08

    I was running phpgedview on another host with 5.2. The new host had 5.3 so it wasn't so much upgrading. Initially there were 5.3 specific errors, which I saw were fixed in svn so I decided to use the repo instead of the latest stable release.

    Database is mysql, params are pretty standard.

    $DBTYPE='mysql'; //- type of database to connect when using the PEAR:DB module
    $DBHOST='localhost'; //- Host where MySQL database is kept
    $DBPORT=''; //- Database port, leave blank for default
    $DBUSER='root'; //- MySQL database User Name
    $DBPASS=''; //- MySQL database User Password
    $DBNAME='phpgedview'; //- The MySQL database name where you want PHPGedView to build its t

     
  • eydaimon
    eydaimon
    2009-11-10

    The link you posted doesn't work.

    I'm using the macport for php5
    php5 @5.3.0_3+darwin_10+fastcgi+macosx (active)

     
  • Greg Roach
    Greg Roach
    2009-11-10

    That's because sourceforge uses particularly annoying forum software that converts underscores to italics.  Look at the word darwin in your own post.

    Replace the italic 5 with "underscore 5 underscore" and the italic connect with "underscore connect underscore".

     
  • kiwi_pgv
    kiwi_pgv
    2009-11-10

    > That's because sourceforge uses particularly annoying forum software that converts underscores to italics. Look at the word darwin in your own post.

    Yes, so we're testing out an alternative. try it yourselves and see what you think. Its accessed under the "Hosted Apps" menu link above here. Click on "punBB".

     
  • eydaimon
    eydaimon
    2009-11-12

    Either way… can you use a url shortener to post the URL?

    in fact, use mine :) 

      : http://tcbp.net

     
  • eydaimon
    eydaimon
    2009-11-15

    OK, so I checked it out. I don't see anything here that helps me figure out the problem.

      : http://tcbp.net/3K

     
  • Greg Roach
    Greg Roach
    2009-11-15

    The page is an automated unit-test of the latest build.  The error has gone, implying that the bug has been fixed.

     
  • eydaimon
    eydaimon
    2009-11-15

    Well, I'm using the stable release from june: http://www.php.net/downloads.php#v5

    Are you saying this release is bugged then?

     
  • Greg Roach
    Greg Roach
    2009-11-15

    Yes.  It had a known bug (as demonstrated by the original link I posed), which gives the same error message that you reported.

    This doesn't mean that this is the cause of your error, but it is the one I would look to first.

     
  • eydaimon
    eydaimon
    2009-11-16

    well, I don't have another build I can use. PHP.net has not released another stable version with that as bugfix.

     
  • Lester Caine
    Lester Caine
    2009-11-16

    eydaimon - The main problem here is that PHP 5.3 is not yet fully supported by many third party libraries, and does still have a number of bugs. 5.3.1 is in RC but this does not fix the many other libraries that now need updating. This is why 5.2 is still being supported and bug fix releases done - 5.2.11 is due soon. Where Linux distributions are pushing 5.3 out many users have asked to roll back!

    fisharebest -  has the PGV codebase been fully checked against 5.3, or is it just a matter of hiding the warnings at present? I know in my own code there are a number of depricated warnings that need some rethinging to work around :(

     
  • Greg Roach
    Greg Roach
    2009-11-16

    <<has the PGV codebase been fully checked against 5.3>>

    It's been recoded to work with all the issues that we've found.  I run my development machine on the highest level of compatibility/warnings, and I haven't seen any issues for a while.

    There may well be further issues in areas of the code that get used infrequently.