PHP 5.3

Pilgrims
2009-10-09
2013-05-30
  • Pilgrims
    Pilgrims
    2009-10-09

    Hi guys, not sure if you already know but PGV doesn't seem to run on PHP5.3.

    A friend was going to set PGV up on their local system to help me troubleshoot a watermarking issue, but found they couldn't.  The difference being PHP versions.

     
  • Greg Roach
    Greg Roach
    2009-10-09

    I'm using PGV on PHP5.3 right now.

    In PHP5.3, there is a config setting that treats deprecated features as errors.  If you remove this option, you should be fine.

    I've been working through various compatibility issues (many of which are in 3rd party libraries, so I need to pass patches upstream), and will all be removed in PGV4.2.3

     
  • Pilgrims
    Pilgrims
    2009-10-10

    Okey dokey - will let them know.  Thanks.

     
  • Lester Caine
    Lester Caine
    2009-10-10

    PHP5.3 has been a long time coming, but some of the internal changes ARE causing problems for third party packages, and so deployment will probably be somewhat delayed in the field. I've seen a few linux distributions pushing it out as a normal update, but then getting requests to get back to PHP5.2. It should be treated more like a major version change rather than the minor one it's numbering would imply, but we have had this before with PHP - how many people got stung with PHP5.1? It's the 'odd version number' problem over again ;) Many of these changes should have been saved to go with PHP6 and clean unicode implementation, but it looks like that is going to be delayed even further.

     
  • matthys
    matthys
    2010-10-24

    I do say I was surprised PGV was not PHP 5.3 valid.

    Did a upgrade of PHP from 5.2.14 to 5.3.3 (Gentoo) and PGV (4.2.3) got broken.
    Bit sad as it's now a year further and no optimization done…

    I downgrade PHP again… but hope PGV will be ready for it soon.

     
  • Stephen Arnold
    Stephen Arnold
    2010-10-24

    Matthys
    I'm using PHP v5.3.2 without issue with PGV v4.2.3+ (svn). What problems are you having? You posted on a thread that was more than a YEAR old - and all changes to the code to have it compatible with PHPv5.3 were included in releases since that time.
    -Stephen

     
  • Peter
    Peter
    2012-02-07

    I'm having the same problem after having updated the base OS (openSuSE to v12.1 from 11.3) which has updated PHP to v5.3.4

    trying to update dates anywhere on PGV brings up the following error:

    ERROR 2: preg_replace(): Compilation failed: POSIX collating elements are not supported at offset 3
    0 Error occurred on in function preg_replace
    1 called from line 241 of file functions_date.php in function default_edit_to_gedcom_date
    2 called from line 2244 of file functions_edit.php in function check_input_date
    3 called from line 2215 of file functions_edit.php in function handle_updates
    4 called from line 1489 of file edit_interface.php
    Warning: preg_replace(): Compilation failed: POSIX collating elements are not supported at offset 3 in /srv/www/htdocs/family/includes/functions/functions_date.php on line 241

    error_reporting is set to E_ALL & ~E_DEPRECATED & ~E_NOTICE

    any help much appreciated

    Peter

     
  • Stephen Arnold
    Stephen Arnold
    2012-02-07

    Peter
    PHPv5.3.4 is almost ancient now. If you just updated, you should have more current versions. The most recent stable release is v5.3.10 (just released, but several important fixes) and v5.4 will be out shortly considering they are on RCv6.

    I can't speak to OpenBase, but I have no issues with the current SVN code and PHPv5.3.9 on my MacOS-X Snow Leopard (10.6.8) and Apache-2+. I would suggest you may be unable to use the OS you describe and you may need to move to webtrees as I don't believe anyone here will be able to code a fix (if truly needed) for your problem.

    What version of PGV are you using? If not v4.3 (SVN), then try that first since that is the version you should be using. There were many fixes for PHPv5.3 in the code from older versions.
    -Stephen

     
  • Peter
    Peter
    2012-02-08

    Hi Stephen,

    thanks for the reply. I've got PHP up to v5.3.8 which is the latest version marked stable in the SuSE repositiories. I'm using v4.3 of PGV.

    Still got the same problem

    Peter

     
  • Peter
    Peter
    2012-02-09

    I've now got the add-on repository install so I've upgraded to PHP 5.3.10… and I'm still getting the same error. I think there is probably some module missing, but I can't work out what…

    Peter

     
  • Stephen Arnold
    Stephen Arnold
    2012-02-09

    This still appears to be a POSIX issue with the code that may be unique to your OS installation.
    Here's a good recap of the problem on another set of code:
    http://stackoverflow.com/questions/7173787/compilation-failed-posix-collating-elements-are-not-supported
    I've reviewed the PGV date function and it is not obvious if there is any problem. I don't have this error, on v5.3.6 or v5.3.10 of PHP and PGV, so I can't help further other than my suggestion that maybe you install webtrees and try it.
    -Stephen

     
  • Gerry Kroll
    Gerry Kroll
    2012-02-09

    I agree that this might be a PHP bug, specific that implementation of PHP.

    The code appears to transform full-stops in the text to full-stops enclosed by paired square brackets.  I have no idea what the code is actually trying to do here.

    From what I can gather, the POSIX elements that aren't supported would have the appearance of some string enclosed by a pair of full-stops which are then enclosed by paired square brackets.  In other words, you need a pair of full-stops inside a set of square brackets for that string to be POSIX element.  A single full-stop inside a set of square brackes is not a POSIX element.

     
  • ggpauly
    ggpauly
    2012-03-19

    Hi Peter - did you get this resolved?

    It's very curious that you're having trouble while most others don't.

    I didn't see that anyone had asked - are you running PHP as an apache module (mod_php)?  I don't know that that would cause this problem, but I'd guess most folks run PHP in cgi mode, or fast_cgi mode.

     
  • Peter
    Peter
    2012-03-19

    In the end I revert back to older version of the OS. I never did get to find out quite why it errored.

    Peter

     
  • YvesH
    YvesH
    2012-04-06

    Just installed PGV v4.2.4 under PHP 5.3.10 and mySQL 5.0.9. and got, apart from errors when trying to generate some reports (deprecated function calls), a most annoying problem. Individual full names appear in PGV and in the DB without a blank between the (last) given name and the surname. Same occurs under PHP v5.2.17. The ANSI coded GEDCOM file generated by Heredis 10 looks OK. Manually correcting in the mySQL DB is of no use.
    Any hint ?
    Yves

     
  • Stephen Arnold
    Stephen Arnold
    2012-04-06

    Yves
    PLEASE -
    1) do NOT resurrect ancient threads.
    2) do NOT use open discussion for HELP. Use the help forum for help.

    PGV 4.3 (svn) works fine with PHP 5.3.10. If you review the requirements, you'll see the minimum MySql is
    http://wiki.webtrees.net/System_requirements
    MySQL 5.0.13 or later. Note that webtrees can share a single database with other applications, by choosing a unique table prefix during configuration. If the number of databases is not restricted, you can set up a database purely for use by webtrees and create a separate user and password for only your genealogy.

    You will not be able to use 5.0.9 with any PGV installation reliably.
    -Stephen

     
  • Gerry Kroll
    Gerry Kroll
    2012-04-08

    Yves:
    Please start a new thread in the Help forum.  Your question/problem will be answered there.