Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#2462 Remote media not displayed

v4.1.6
closed-rejected
nobody
None
5
2009-01-09
2009-01-05
graeme
No

Since upgrading to PGV 4.1.6, media files held on a remote server are listed but not displayed on the medialist page (or elsewhere); instead the 'file not found' error message is shown. Locally stored media display properly.

I have checked that the remote files are publically accessible and that the correct URL is recorded in both the PGV database and the GEDCOM. All OK.

The problem appears to be that the page writing script doesn't recognize the URL as a remote address, and incorrectly re-writes the address to the local media folder. That is, the remote file 'http://dl.getdropbox.com/u/339409/pgv/Skaugum-01.jpg' is re-written to the page as 'media/pgv/Skaugum-01.jpg'. PGV creates the 'media/pgv/' folder automatically but it is empty.

The mediaviewer page lists the correct URL for the external media file and even displays a thumbnail of the image, but still shows the 'file not found' message. The thumbnail is not held on the local server, so PGV must be accessing the correct URL even though it says it can't find it.

The thumbnail on the mediaviewer page is 'dead'; it is not linked to anything.

Discussion

  • graeme
    graeme
    2009-01-09

    Please ignore this Bug Report. It turns out that after updating to PGV 4.1.6, I somehow turned off the 'multimedia->keep links' setting for the GEDCOM. Re-activating this setting fixes the problem. Remote media are once again displaying perfectly.

     
  • Greg Roach
    Greg Roach
    2009-01-09

    • status: open --> closed-rejected