#2452 v4.1.6 not compatible with php 4?

v4.1.6
closed-fixed
nobody
None
5
2009-04-18
2009-01-01
Robert 2S
No

Some pages stop loading half way. In the html of the loaded part, I see a fatal error report saying that function php_print_backtrace() was not found. I looked up this function in the php reference, and found that it is a php 5 function, that does not exist in php 4. I use php 4.3.11 (since my web host provider does not upgrade to php 5). I did not expect this failure, since PhpGedView v4.1.6 is supposed to be the last version that is compatible with php 4. Do I overlook something here?

Note: I installed v4.1.6 as part of a migration from v4.0.1; I followed all upgrade guidelines.

Discussion

1 2 > >> (Page 1 of 2)
  • Robert 2S
    Robert 2S
    2009-01-01

    Oops, I wrote php_print_backtrack() but that should be debug_print_backtrace().
    And of course, a happy new year to everybody!

     
  • kiwi_pgv
    kiwi_pgv
    2009-01-01

    I would say there are two problems her:
    1 - yes you are right, that function should not be in 4.1.6. Every effort was made to ensure all php5-only functions were removed before release, but clearly this one sneaked through.

    2 - the reason it got through (I suspect) is that none of the testers had an error in their GEDCOM or installation that triggered the use of this function. Therefore, even without it, you would still have a problem.

    The function exists in a few places - can you give us the exact wording of that fatal error? It should say which file failed.

    As a final note - it is hoped to release PGV 4.2 in a few weeks. If you want to use it (and it is highly recommended) you will HAVE to persuade your host to upgrade to PHP 5.2.3 or greater. Perhaps point out to them that PHP 4 hasn't been supported by its own creators since the end of 2007!

     
  • kiwi_pgv
    kiwi_pgv
    2009-01-01

    I would say there are two problems her:
    1 - yes you are right, that function should not be in 4.1.6. Every effort was made to ensure all php5-only functions were removed before release, but clearly this one sneaked through.

    2 - the reason it got through (I suspect) is that none of the testers had an error in their GEDCOM or installation that triggered the use of this function. Therefore, even without it, you would still have a problem.

    The function exists in a few places - can you give us the exact wording of that fatal error? It should say which file failed.

    As a final note - it is hoped to release PGV 4.2 in a few weeks. If you want to use it (and it is highly recommended) you will HAVE to persuade your host to upgrade to PHP 5.2.3 or greater. Perhaps point out to them that PHP 4 hasn't been supported by its own creators since the end of 2007!

     
  • Robert 2S
    Robert 2S
    2009-01-03

    I belief that one of the fatal errors was reported at a line containing preg_match_all() in includes/functions.php. However, I can't reproduce this anymore, since I migrated to another webserver with php 5 (luckily, my provider offered the migration).

    Now, with php 5, PhpGedView 4.1.6 runs without any failure! That may suggest that my GEDCOM installation does not contain errors. In that case, I suspect that the observed failures with php 4 are solely caused by php 4 incompatibilieis in PhpGedView 4.1.6... I however cannot investigate this any further now, since I don't have php 4 anymore.

    Can we add a note to PhpGedView 4.1.6 about the incompatibility with php 4 to warn other users?

     
  • kiwi_pgv
    kiwi_pgv
    2009-01-03

    <<Can we add a note to PhpGedView 4.1.6 about the incompatibility with php 4
    to warn other users?>>

    Not really much point. 4.2 should be released very soon, and this will require a minimum of PHP 5.2.3

    There will also be a 4.1.7, which is 4.1.6 plus all the patches so far, but I doubt anybody still using PHP 4 will get very much support anymore.

     
  • kiwi_pgv
    kiwi_pgv
    2009-01-03

    <<Can we add a note to PhpGedView 4.1.6 about the incompatibility with php 4
    to warn other users?>>

    Not really much point. 4.2 should be released very soon, and this will require a minimum of PHP 5.2.3

    There will also be a 4.1.7, which is 4.1.6 plus all the patches so far, but I doubt anybody still using PHP 4 will get very much support anymore.

     
  • Greg Roach
    Greg Roach
    2009-01-03

    I'd like to fix this bug, and create a patch.

    But I can only do that if I can reproduce it.

     
  • Greg Roach
    Greg Roach
    2009-01-07

    • status: open --> pending-fixed
     
  • Greg Roach
    Greg Roach
    2009-01-07

    I have removed references to debug_print_backtrace() from the 4.1 branch in SVN.

    Since I intend to roll up all the 4.1.6 patches into a 4.1.7 release shortly, I'm not going to bother create a separate patch for this.

     
    • status: pending-fixed --> closed-fixed
     
1 2 > >> (Page 1 of 2)