#2231 [3872] famlist.php alpha=, link for the (none)

v4.1.5
closed-fixed
Greg Roach
None
5
2009-01-09
2008-09-16
Mark Hattam
No

When I go to the famlist.php I see the row of possibilites as I expect.

?|A|B|C| ... |Y|Z|(unknown)|ALL

If I then click the "all", I get the column listing

(None)
?
Add...
Al...
Av...

and so on

The links for all the names work except for the first one.

The ? for instance links to
...phpgedview/famlist.php?surname=%3F

The Add... links to
.../phpgedview/famlist.php?surname=ADD...

But the (None) links to
...phpgedview/famlist.php?alpha=,

The Spouses column shows the number 220 for (None), but clicking the link brings up no table.

Elsewhere I believe the link is
alpha=%40
rather than
alpha=,

Oh ... and shouldn't (None) be (unknown) for consistency?

Mark

Discussion

1 2 3 4 > >> (Page 1 of 4)
  • Greg Roach
    Greg Roach
    2008-09-16

    This is part of the new functionality to allow individuals to have no surname, as opposed to an unknown surname.

    For example, I have a ancestor

    1 NAME Harold II
    2 GIVN Harold
    2 NSFX II

    This is not "Harold Unknown", it is just "Harold". If he was Harold "Unknown", his gedcom would have slashes: "1 NAME Harold // II"

    The comma was chosen to indicate this to use the same logic used for unknown surnames. Consider these "sortable" names:

    Smith,John
    @N.N,John
    ,Harold

    You'll see that the comma is the first character of this name.

    The "?" means you probably have a surname "?" in your gedcom

     
  • Mark Hattam
    Mark Hattam
    2008-09-16

    I'm not asking about the /?/ occurances. I do have plenty of people in the GEDCOM with /?/ surnames, because although I don't know what their surname is, I do know they had one. This happens often with data from christenings where the father's name is fully known, but the wife has only her christian name shown. Another example is when I have a mother-in-law on a census who's a widow ... I only know her husband's surname and her christian name.

    I'm asking about the ones which seem to be for the occurances where I know the father's name and have no idea at all what the mother's name is, and currently PGV puts in (unknown),(unknown). This happens regularly when I use the parish register (or marriage certificate) information which of course only names the father. I don't have anyone in the GEDCOM (yet) with a known-to-be-no-surname.

    In one GEDCOM I have 220 alleged occurences for the (None) that is currentl linked with the alpha=, but clicking that link does not present me with me with a list of 220 families. It shows me no list at all.

    I do not currently see an entry in the famlist for the (unknown) people, who happen also to number 220 (quite a coincidence) and who would be found with the alpha=%40 link.

    Which is why I think the logic isn't currently working, and the (unknown)s are getting mixed up with the (None)s.

    Mark

     
  • Meliza Amity
    Meliza Amity
    2008-09-29

    Mark,

    Try SVN 3959 and make a change to the unknown names that you see in the none list.
    For me this solved the problem.

    Meliza

     
  • Greg Roach
    Greg Roach
    2008-10-02

    • status: open --> pending-fixed
     
  • Greg Roach
    Greg Roach
    2008-10-02

    Mark - this is believed to be fixed, but you'll probably need to reimport to update the database tables.

     
  • Mark Hattam
    Mark Hattam
    2008-10-02

    • status: pending-fixed --> open-fixed
     
  • Mark Hattam
    Mark Hattam
    2008-10-02

    OK ... SVN 3988 ... (just got home so first chance)

    Re-imported GEDCOMs ... almost everything fixed.

    The row of items across the famlist.php page now makes good sense to me ...
    ? | A | B | C ..... X | Y | Z | (unknown) | ALL
    these all "map" to the groupings I expect ...
    ? maps to people in families who resolve to indi's such as 1 NAME Jane /?/
    (unknown) maps to families where I have a completely unknown spouse, ie (unknown), (unknown) and there is no INDI to resolve to.

    The only item that isn't covered is when I click the ALL, I get the surname - count(surname) listing table starting with the ?'s, then the A's, B's etc down to Y's and Z's ... but no "(unknown)".

    Mark

     
  • Greg Roach
    Greg Roach
    2008-10-09

    <<The only item that isn't covered is when I click the ALL, I get the
    surname - count(surname) listing table starting with the ?'s, then the A's,
    B's etc down to Y's and Z's ... but no "(unknown)".>>

    I've just tried with latest SVN (4039), and I see the (unknown) surname at the bottom of the ALL list (both fam and indi).

    Is it still an issue on your site?

     
  • Greg Roach
    Greg Roach
    2008-10-09

    • status: open-fixed --> pending-fixed
     
  • Mark Hattam
    Mark Hattam
    2008-10-09

    SVN4041
    When I click the "All" in the row of
    ? | A | B | ... | Y | Z | (unknown) | ALL

    I now get the surname - count(surname) table starting with
    (None) 573
    ? 510
    followed by the surnames in A-Z order.

    The problem now is that here I get a "None" and not a "unknown" ... and hence the link is to alpha=, and not alpha=%40 ...

    (I haven't yet re-imported the GEDCOM this morning)

    Mark

     
1 2 3 4 > >> (Page 1 of 4)