Apache or FrontPage Extension Problem??

  • Lech Walensa
    Lech Walensa

    Hey folks.  My host has decided to cripple us with a truncated ftp listing of 2000 files.  So I went a-looking for another file management tool and found you guys!!  Loved the screenshots, was VERY excited about trying you out.  But I'm not getting all the way into the tool.  I get an initial window with an "Enter" button and after I click on it, I get a 500 server error with this text on the bottom:

    Apache/2.2.9 (Unix) mod_ssl/2.2.9 OpenSSL/0.9.7a mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/ Server at myserver.com Port 80

    I'm running on Linux with FrontPage extensions installed to run a lousy old site we're either too old or too lazy to let go of.  I think the error I'm seeing is due to the server not liking your script due to the .htaccess settings to run Frontpage.  I did try changing the first line of your code to read "<?php" instead of just the "<?" but that didn't work. Tried messing with permissions all the way up to 777 to see if that made a difference, didn't.  And I tried poking around in the htaccess file to try and add some settings to better embrace php, but that didn't work either and wound up trashing any php I'd integrated with html pages, had to reinstall FP Extensions to get back up and running.  Mind you, I am already running php code to run some RSS stuff and I'm running phpbb2 for a forum, and I've got a php guestbook so I know php works.

    I'm running PHP Version 5.2.6 with Apache 2.2.9 on a Linux box...so, any ideas why I'm getting that error??? I know you guys are busy and this is fah-ree software, but any help would be greatly appreciated.  :)  Take care.

    • david62

      If you're getting the 'enter' button then you're nearly there. Firstly, you should check phpinfo(); 'register_globals' should be 'on'. If its off then you can't use phpFileManager as it is.
      Some others have reported a similar problem I just wonder if this is the cause.

    • In those cases I would expect a more or less verbose error message in apache's error.log - have you had a look there?

    • david62

      Oops - register_globals is not the issue here since the script will register the globals anyway. If you're able to, you could try running the script on another domain on the same server without .htaccess to see if it fires up.