#319 SQL request sometimes fail

v0.9.1
closed
nobody
None
5
2005-09-19
2005-05-12
Matthieu Pupat
No

Sometimes when I try to display a bug, the SLQ request
fails.

I then get the message:

DB Error: no such field
select bug_id, reporter.login as reporter, owner.login
as owner from phpbt_bug b left join phpbt_auth_user
owner on b.assigned_to = owner.user_id left join
phpbt_auth_user reporter on b.created_by =
reporter.user_id left join phpbt_auth_user lastmodifier
on b.last_modified_by = lastmodifier.user_id left join
phpbt_resolution resolution on b.resolution_id =
resolution.resolution_id, phpbt_severity severity,
phpbt_status status, phpbt_os os, phpbt_version
version, phpbt_component component, phpbt_project
project, phpbt_site site where b.severity_id =
severity.severity_id and b.status_id = status.status_id
and b.os_id = os.os_id and b.version_id =
version.version_id and b.component_id =
component.component_id and b.project_id =
project.project_id and (b.status_id in
(1,2,3,4,10,8,5,6,9)) and (b.project_id = 2) and
b.site_id = site.site_id and bug_id <> 360 order by v2
asc, bug_id asc LIMIT 0, 1 [nativecode=1054 ** Unknown
column 'v2' in 'order clause']

Where does the problem come from ?

Discussion

  • Ulf Erikson
    Ulf Erikson
    2005-08-16

    Logged In: YES
    user_id=592447

    Please check whether this is still a problem in v1.0.

     
  • Ulf Erikson
    Ulf Erikson
    2005-09-19

    Logged In: YES
    user_id=592447

    I think this is fixed.

     
  • Ulf Erikson
    Ulf Erikson
    2005-09-19

    • status: open --> closed