PostgreSQL for Mac 9.0.0 and 8.4.4 Available

There are a couple of things to note, so read up a bit before you go installing. First of all, there is no longer multiple installations for the two versions.

  1. Everything is now in one installer. 9.0.0 is the default, but you can select the 8.4.4 version from the custom installation option.

  2. The installer now goes to the /Library/PostgreSQL folder instead of /Library/PostgreSQL8. If you would like, you can move your existing folder to that location for an upgrade, or you can leave them in place side by side. Symlinks will work too.

  3. We have dropped support for 10.4. As we migrate to use the newer features of the Cocoa platform, 10.4 is becoming increasingly difficult to keep in sync. With that in mind, we have dropped support for 10.4. We can support it if needed, but it is time consuming.

  4. pgAdmin is now installed as part of the installation

  5. The Automator Query actions are now installed by default.

  6. JDBC4 is now in the installer, but it is an optional installation.

  7. Symlinks are now correct with regards to doc and man.

  8. pg_set_version.sh will no longer create bogus doc and man folder links.

Posted by Andy Satori 2010-09-24