Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#296 regression (?): "No room for a new \dimen"

v1.0 (example)
open
nobody
None
5
2014-06-13
2014-03-03
Scott Kostyshak
No

Upgrading the pgf package to TeX Live revision 33057 (which seems to be pgf v. 3.0.0) from revision 22614 (pgf v. 2.10) lead to me being unable to compile a document. Here is an MWE of that document:

\documentclass[english]{article}
\usepackage{xy}
\usepackage{qtree}
\usepackage{pstricks}
\usepackage{pst-plot}
\usepackage{tikz}

\begin{document}
\section{Testing}
Testing
\end{document}

Attached also are the logs of compilation of that .tex file (with 'latex') before ("good") and after ("bad").

I have no idea if this is a regression, and if it is, if pgf is the one who caused it. Because it looks like it involves the interaction of loading several packages, I wouldn't be surprised if one of the other packages is to blame or if I am to blame by loading packages that aren't supposed to be used together. In any case, pgf seemed like a good place to start. I did read the README and it stated that in "normal circumstances" old code should work. I'm not sure if the above MWE represents a normal circumstance.

I've reproduced the above described behavior on Ubuntu 13.10 and 14.04.

Please let me know if there's anything else I can do.

Thank you for all of your work on pgf and congratulations on a big 3.0.0 release.

2 Attachments

Discussion

  • U_Fischer
    U_Fischer
    2014-03-03

    Add \usepackage{etex} to your document. http://www.tex.ac.uk/cgi-bin/texfaq2html?label=noroom

    Ulrike Fischer

     
    • Thanks Ulrike, that works.