ready to run version of projectforge accessible from lan?

Help
Thomas
2013-04-30
2013-05-13
  • Thomas
    Thomas
    2013-04-30

    Hi,

    we want to evaluate projectforge for our company.

    Does a possibility exist to make the ready to run version of projectforge accessible from lan, not only from localhost? Running on a CentOS6.

    Best, Thomas

     
    Last edit: Thomas 2013-04-30
  • Kai Reinhard
    Kai Reinhard
    2013-04-30

    Hi,
    ProjectForge is automatically available from remote clients, please use http://192.168.2.111:8080/ProjectForge instead of http://localhost:8080/ProjectForge in the client browser. Replace 192.168.2.111 by the ip address of the server where ProjectForge runs. Later you may give a name for the ProjectForge server in your name server in your LAN or Internet for a more convenient access: https://projectforge.my-company.com/.
    If this doesn't work you may have a firewall between the ProjectForge server and the browser client which blocks the connection.
    Regards
    Kai

     
    Last edit: Kai Reinhard 2013-04-30
  • Thomas
    Thomas
    2013-05-02

    Thank you, it was my fault (networking-issue).

    At the moment I start the server by using x from my client. Does a possibility exist to integrate the serverstartup within the .sh script?

    And another one: If I enable LDAP authentication (simple) it isn't possbile for me to use local users anymore. Unfortunatly the admin user too.

    Best, Thomas

     
    Last edit: Thomas 2013-05-02
  • Kai Reinhard
    Kai Reinhard
    2013-05-02

    For running ProjectForge in production mode you should install a Tomcat web server with ProjectForge.

    There is no shell script yet available for starting ProjectForge with the embedded web server, but that would be a good idea and therefore it will be available in version 5.1 coming soon: https://www.projectforge.org/jira/browse/PF-426

    LDAP: Yes, that's a little bit tricky, I tried it a few minutes ago: Please login as admin user (without configured LDAP) by using the stay-logged-in-check-box in the login screen. Now restart ProjectForge with configured LDAP and use the same browser (you should be logged in). Go to the users list and select the option "local user" in the LDAP section for the users which shouldn't be authenticated against LDAP and save them. Hope, this will help you. (I'm adding this to the AdministrationGuide, thanx for reporting this.)

    Best regards, Kai

     
    • Thomas
      Thomas
      2013-05-03

      Hi Kai,

      thank you. The workaround you mentioned worked and I'm now able to login with the admin user (local) and with ldap users.
      The next issue is: If I use my ldap account for login, the ldap-user doesn't appear within the user interface for the admin user. So I can't configure the ldap users within projectforge (setting privileges, tasks, etc.)

       
  • Kai Reinhard
    Kai Reinhard
    2013-05-06

    Hi Thomas, you may add the LDAP user in ProjectForge and may set the privileges etc. In LDAP-simple mode only the password will be checked against LDAP, the user must exist in ProjectForge.

     
  • Kai Reinhard
    Kai Reinhard
    2013-05-07

    Hi, may-be the user-mode is the mode you may need. Configure a ldap manager user in config.xml (with at least read-access to all users) and the users will be created and synchronized in ProjectForge automatically.
    Regards
    Kai

     
    Last edit: Kai Reinhard 2013-05-07
  • Thomas
    Thomas
    2013-05-13

    Hi,
    hm. If I use simple mode I can't create user within projectforge because it says "User with this username already exists". For sure it exists. Within LDAP. But I don't see the user within projectforge.

    If I use user-mode I get the following error after trying to login with ldap:

    HTTP ERROR 404

    Problem accessing /ProjectForge/wa/error. Reason:

    Not Found
    

    Caused by:

    org.apache.wicket.RestartResponseAtInterceptPageException

    Does a possibility exist to contact you directly? As I said, at the moment we're trying to evaluate.

     
  • Kai Reinhard
    Kai Reinhard
    2013-05-13

    Hi,
    please check if there is a deleted user (click on 'only deleted'). There must be a data-base entry with the same username in ProjectForge. The 404 error should be caused by a previous error. We need your log file for further investigations. You may mail me the log-file (with the messages from the start-up phase until the 404 error) to k.reinhard at me.com. Feel free to remove passwords, urls etc. from the log-file before (but not the whole log messages).
    Regards
    Kai